1. Joost Member

    Htaccess met .well-known/caldav

    Topic geplaatst op: 01-08-2020 om 14:23

    Ik heb bij jullie nextcloud draaien, maar ik heb een probleem bij het resolven van https://DOMAIN/.well-known/caldav (en carddav).
    Via nextcloud heb ik een .htaccess gekregen die gewoon goed zou moeten werken (ik heb het via verschillende test tools nagekeken. Maar steeds als ik naar `PROPFIND /.well-known/carddav` ga krijg ik 405 Method Not Allowed. De .htaccess heb volledig leeg gegooid en enkel deze regels laten staan:
    Header set Strict-Transport-Security "max-age=15552000; includeSubDomains" env=HTTPS
    <IfModule mod_rewrite.c>
    RewriteRule ^\.well-known/carddav /remote.php/dav/ [R=301,L]
    RewriteRule ^\.well-known/caldav /remote.php/dav/ [R=301,L]
    </IfModule>
    Maar ook dan hetzelfde verhaal. Wederom Http error 405.

    Als ik de punt weghaal en ook de requests stuur zonder punt dan lijkt het wel te werken. Is het zo dat jullie iets doen met .well-known doordat SSL is geactiveerd? Hoe kan ik deze redirects wel realiseren als deze niet bij .htaccess aan komen?

    Dit stuk (ook onderdeel van nextcloud) heeft wel invloed:
    <IfModule mod_rewrite.c>
    Options -MultiViews
    RewriteRule ^core/js/oc.js$ index.php [PT,E=PATH_INFO:$1]
    RewriteRule ^core/preview.png$ index.php [PT,E=PATH_INFO:$1]
    RewriteCond %{REQUEST_FILENAME} !\.(css|js|svg|gif|png|html|ttf|woff2?|ico|jpg|jpeg|map|webm|mp4)$
    RewriteCond %{REQUEST_FILENAME} !core/img/favicon.ico$
    RewriteCond %{REQUEST_FILENAME} !core/img/manifest.json$
    RewriteCond %{REQUEST_FILENAME} !/remote.php
    RewriteCond %{REQUEST_FILENAME} !/public.php
    RewriteCond %{REQUEST_FILENAME} !/cron.php
    RewriteCond %{REQUEST_FILENAME} !/core/ajax/update.php
    RewriteCond %{REQUEST_FILENAME} !/status.php
    RewriteCond %{REQUEST_FILENAME} !/ocs/v1.php
    RewriteCond %{REQUEST_FILENAME} !/ocs/v2.php
    RewriteCond %{REQUEST_FILENAME} !/robots.txt
    RewriteCond %{REQUEST_FILENAME} !/updater/
    RewriteCond %{REQUEST_FILENAME} !/ocs-provider/
    RewriteCond %{REQUEST_FILENAME} !/ocm-provider/
    RewriteCond %{REQUEST_URI} !^/\.well-known/(acme-challenge|pki-validation|carddav|caldav)/.*
    RewriteRule . index.php [PT,E=PATH_INFO:$1]
    RewriteBase /
    <IfModule mod_env.c>
    SetEnv front_controller_active true
    <IfModule mod_dir.c>
    DirectorySlash off
    </IfModule>
    </IfModule>
    </IfModule>

    dan gaan alle requests wel met een HTTP 302 naar /index.php/apps/files/.

    Reageer
  2. Er zijn nog geen reacties.