1. Karen Member

    WP Contact Form 7 bericht sturen faalt

    Topic geplaatst op: 24-04-2020 om 10:19

    Hallo

    Ik heb gemerkt dat bij mijn wordpress, die Contact Form 7 gebruikt, er telkens een bericht komt dat het bericht (de mail dus) niet verzonden kan worden.

    Heb dan WP Mail SMTP geïnstalleerd, de instellingen gezet zoals aangegeven op https://www.versio.nl/artikelen/31-wat-zijn-de-pop-imap-en-smtp-gegevens-van-mijn-email-account

    met mail.axc.nl, SSL, poort 465, user: mijnemail@mijndomein.be / password: zoals ik had aagegeven

    Als ik een test mail door de plugin laat sturen, lukt dat niet (foutmelding), dit is de debug log die er uit komt:

    Versions:
    WordPress: 5.4
    WordPress MS: No
    PHP: 7.4.1
    WP Mail SMTP: 1.9.0

    Params:
    Mailer: smtp
    Constants: No
    ErrorInfo: Invalid address: (setFrom) <snip-antispam>@<snip>.be
    Host: localhost
    Port: 25
    SMTPSecure: string(0) ""
    SMTPAutoTLS: bool(true)
    SMTPAuth: bool(false)

    Server:
    OpenSSL: OpenSSL 1.0.2k 26 Jan 2017
    Apache.mod_security: No
    SMTP Debug:
    Invalid address: (setFrom) <snip-antispam>@<snip>.be

    Vermits ik de SSL variant gebruik, bestaat het email account uiteraard (had in een ander topic gelezen dat iemand daar een probleem mee had als deze nog niet bestond).

    Ik zie niet onmiddelijk wat ik nog kan doen of waar er nog debug logging staat om te kijken hoe dit kan opgelost worden. Iemand die iets soortgelijks voorgehad heeft? Kan een Versio mod me eventueel verder helpen?

    Bedankt!

    Reageer
  2. Lars Member
    Reactie geplaatst op: 24-04-2020 om 11:45

    Beste Karen,
    Om goed gebruik te maken van deze optie is het noodzakelijk om een info@ mailadres aan te maken in Direct Admin. Wil je dat doen?

    Hierbij ook nog een verdere uitleg.

    https://www.versio.nl/artikelen/372-hoe-verstuur-ik-mail-via-de-php-functie-mail

    Kun je hiermee verder.

    Met vriendelijke groet,
    Lars Godijn
    Versio

    Vond u dit antwoord nuttig?

  3. Karen Member
    Reactie geplaatst op: 24-04-2020 om 12:04

    Dag Lars

    Het lag blijkbaar aan de php versie, zoals je kan zien had ik 7.4 ingesteld, ik ben even terug naar 7.3 gegaan en onmiddellijk werkte de mails versturen wel. Zou je kunnen vertellen waarom het fout loopt bij 7.4 en wel werkt met php versie 7.3?

    Vond u dit antwoord nuttig?

  4. Robbert Member
    Reactie geplaatst op: 16-07-2020 om 13:03

    Kijk, ik ben dus niet de enige met dit probleem.
    :)
    Heb je al antwoord op je vraag gekregen en is het nu opgelost?
    Het schijnt niet aan PHP versie 7.4 zelf te liggen, maar aan een module die wordt gebruikt.

    Probleem schijnt te liggen in de PCRE module die php gebruikt:

    PHP 7.4 met PCRE 10.31 werkt niet, authenticatie issue
    PHP 7.4 met PCRE 10.33 werkt wel volgens de info die ik heb gevonden

    Hopelijk kan/wil Versio dit fixen, zodat we weer gebruik kunnen maken van PHP 7.4

    Vond u dit antwoord nuttig?