1. Marjolein Member

    SSL certificaat, site niet meer bereikba

    Topic geplaatst op: 09-01-2019 om 12:18

    Beste

    Na twijfelen, omdat een andere provider waar ik een site host een pak goedkoper is en je de SSL erbij krijgt zonder installatiegedoe. Maar ik heb ik toch de site verlengd bij Versio. De SSL heb ik extra bij gekocht en geïnstalleerd volgens stappenplan. Met als gevolg dat de site vandaag plat ligt en na min of meer wat te kunnen herstellen, ik de backend op geen enkele manier nog kan bereiken. Het ging helemaal de mist in na het installeren van die 'makkelijke' plugin voor Wordpress :/ Deze plugin heb ik verwijderd met filezilla, nu werk de site terug min of meer (afbeeldingen zijn weg door broken link), maar ik kan nog steeds niet naar de backend geraken. Het is een ramp.
    Elke stap is uitgevoerd zoals beschreven.
    Ik heb een backup genomen.

    Vg Marjolein

  2. Christian Member
    Reactie geplaatst op: 09-01-2019 om 13:07

    Om SSL toe te passen moet je eerst een geldig certificaat hebben. Dat heb je zie ik. Daarna moet je op het volgende letten:

    - WordPress > Instellingen > Algemeen: de home/site URL moet met https:// beginnen

    - In je .htaccess bestand moet je SSL forceren. Dat kan met de volgende code:

    ##------Forceer HTTPS verbinding geheel domein------##
    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]
    ##

    - En als laatste moet je goed kijken of je nergens refereert naar een http:// bron. Dus goed kijken in je paginas/posts or er ergens urls zijn die met http:// beginnen. Zie je deze wel, dan verander je het naar https://.

    Leeg ook je cache & cookies tijdens het testen.

    Vond u dit antwoord nuttig?

  3. Marjolein Member
    Reactie geplaatst op: 09-01-2019 om 15:27

    Beste

    Ik heb alles gedaan hoe het moest, stap per stap gevolgd. Ik kreeg foutmelding
    Je verbinding is niet privé
    Cybercriminelen proberen mogelijk je gegevens van www.promac.be te stelen (bijvoorbeeld wachtwoorden, berichten of creditcardgegevens). Meer informatie
    NET::ERR_CERT_AUTHORITY_INVALID

    Via php kon ik de loop uitzetten en zo terug naar de backend geraken en een deel van de site zien. Echter, al de foto's waren ontkoppeld en site was nog steeds niet beveiligd. Ik heb de cache van de site opgeruimd etc. En toen was het helemaal om zeep. database gewist, backup terug gezet, dag werk kwijt ben. Nu staat het nog steeds op onbeveiligd. Er is niets veranderd. Behalve mijn cortisol level.

    Bij het ingeven van click here to paste CA root certificate krijg ik volgende foutmelding
    Success

    Details

    CA Certificate is ok. Your site should be secure within a few minutes.
    Could not find 'X509v3 Subject Alternative Name:' in output

    Vond u dit antwoord nuttig?

  4. Marjolein Member
    Reactie geplaatst op: 09-01-2019 om 15:37

    Nu heb ik via het klantenpaneel - ssl certificaten - Automatische installatie
    het certificaat geinstalleerd en nu doet ie het dus. zonder morren. ik kan naar https://www.promac.be er komt geen foutmelding meer op.
    Morgen het .htaccess bestand bewerken en hopelijk ben ik er dan bijna.

    Vond u dit antwoord nuttig?

  5. Maurice Versio medewerker
    Reactie geplaatst op: 10-01-2019 om 22:42

    Dat komt omdat je niet alles via https inlaad. Er worden nog 30 onderdelen op je site via http ingeladen. Alles moet via https worden ingeladen om het groene slotje te krijgen. (afbeeldingen, linken etc)
    Dit kun je met Wordpress gemakkelijk via de plugin sslfixer oplossen.
    De plugin downloaden via uw dashboard of https://nl.wordpress.org/plugins/ssl-insecure-content-fixer/
    Daarna ga je naar je Wordpress instellingen daar ziet u ssl fixer dan staan.
    Vervolgens klik je bij de settings van ssl fixer op de optie "leg vast"
    De site zal dan nu ook het groene slotje laten zien.

    Vond u dit antwoord nuttig?