1. masterke Member

    Directadmin opties updaten

    Topic geplaatst op: 08-05-2012 om 16:07

    ik wil dus php en mysql en phpmyadmin willen updaten naar de laatste gekende versies,
    maar elke keer ik iets wil updaten krijg ik de melding:

    This is the wrong default PHP in /usr/local/directadmin/custombuild/options.conf set

    heb al vanalles in die file aangepast,maar niks lukt om de dingen te updaten,
    heb al de update file's zelf in die map gezet om ze dan van daaruit te instaleren,
    maar krijg elke keer die fout melding.
    ik moet eerst php updaten en dan mysql en dan pas phpmyadmin om alles perfect te laten werken.
    is er iemand die raad weet hoe dit op te lossen,
    heb op de help pagina's van directadmin ook al gekeken maar elke keer spreken ze van ./build php n
    maar als ik dat doe dan krijg ik die foutmelding.

    hoop dat er iemand kan helpen want heb nu oude versies van php,mysql en phpmyadmin.
    alvast dank aan wie kan helpen.

  2. Un1x Member
    Reactie geplaatst op: 08-05-2012 om 17:50

    Beste,

    Wat is de output van:
    cat /usr/local/directadmin/custombuild/options.conf | grep default_php

    Vond u dit antwoord nuttig?

  3. Un1x Member
    Reactie geplaatst op: 08-05-2012 om 17:50

    Doe ook even:
    php -v

    a.u.b.

    Vond u dit antwoord nuttig?

  4. masterke Member
    Reactie geplaatst op: 08-05-2012 om 20:42

    Op de output vraag van de options.conf krijg ik:
    default_php=5

    bij de php -v krijg ik:

    PHP 5.2.17 (cli)
    zend engine v2.2.0.

    als je meer info wilt dan bekijk ik het eens,
    de php versie is al oud,want er is al een versie 5.4.2.

    Vond u dit antwoord nuttig?

  5. Un1x Member
    Reactie geplaatst op: 09-05-2012 om 12:20

    Masterke,

    Misschien is het handig om de default_php= naar 5.2 te veranderen.. Dit soort dingen horen allemaal overheen te komen met de geïnstalleerde PHP versie.

    Anders kun je ook niet updaten.

    Vond u dit antwoord nuttig?

  6. RayHammer Member
    Reactie geplaatst op: 09-05-2012 om 13:46

    @Jay Maree PHP 5.4.2 zou ik nog niet doen als je ioncube loader ook nodig hebt. Er is nog geen versie van ioncube loader voor PHP 5.4.2

    Vond u dit antwoord nuttig?

  7. masterke Member
    Reactie geplaatst op: 12-05-2012 om 10:13

    Na de default op 5.2 te hebben gezet,nog eens geprobeerd voor een ./build PHP n te doen,en krijg nog steeds de melding dat ik een foute php default heb staan.
    al staat er in mijn systeem info van directadmin dit:
    Php 5.2.17
    MySQL 5.0.67 (wat al oud is ook,en met ./build mysql krijg ik ook die fout van de defaukt php)
    DirectAdmin 1.40.3 (is de laatste versie)
    PhpMyAdmin 2.11.11.3. (wat me ook al oud lijkt)

    dus veel oude versies of is dat standaart in de directadmin versie?????

    Vond u dit antwoord nuttig?