1. Jordi Member

    PHP versie

    Topic geplaatst op: 19-03-2018 om 21:59

    Hey allemaal,

    Onlangs is de versie van PHP veranderd van 7.1 naar 7.2.
    Nu wil het zo zijn dat mijn website nu niet meer werkt omdat gevoelige data versleuteld werd middels de m_crypt functie.

    Sinds php 7.2 is deze functie afgeschreven en kan gebruik gemaakt worden van openssl encrypt.
    Echter laad mijn website nu niet of nauwelijks meer en kan de data niet meer worden versleuteld of ontsleuteld.

    Iemand een idee hoe ik dit kan oplossen?

    Groeten,
    Jordi

  2. Maurice Versio medewerker
    Reactie geplaatst op: 19-03-2018 om 22:05

    Kunt u niet gewoon die php versie lager instellen dan? Dat kunt u zelf via uw directadmin paneel (hostingpakket)
    Inloggen in directadmin > domein aanklikken> dan ziet u onderaan bij uw Advanced features "Select PHP version" . Daaronder kunt u een php versie kiezen voor uw site. En via show "php settings" eventueel extensies activeren of via "Show php Extensions" hier functies voor activeren/aanpassen op uw domein.

    Vond u dit antwoord nuttig?

  3. Jordi Member
    Reactie geplaatst op: 28-03-2018 om 17:26

    Helaas werkte dat ook niet meer.
    Wel bedankt voor de tip!

    Ik heb de code aangepast naar de nieuwe functies. Dat leek me de beste optie.

    Vond u dit antwoord nuttig?

  4. Maurice Versio medewerker
    Reactie geplaatst op: 28-03-2018 om 17:36

    Top ik zie ook dat de site nu weer normaal werkt. Mocht u verder nog vragen hebben horen wij dit graag. Zoniet dan wens ik u nog een fijne dag verder.

    Vond u dit antwoord nuttig?