1. Sjoerd Member

    PHP.ini aanpassen

    Topic geplaatst op: 07-12-2017 om 16:47

    Voor een WP installatie wil ik de max execution time en max input vars aanpassen.
    Via .htaccess lukt dit niet, als ik deze aanpas gaat mijn site 404.
    Dus nu wil ik het aanpassen in php.ini.
    In een ander topic las ik dat ik daarvoor bij 'select php version' moet zijn maar daar vindt ik het niet terug.

    Wat ik wil aanpassen:
    max_execution_time = 200
    max_input_vars = 2000;

    Waar kan ik dit aanpassen?

    Reageer
  2. Gavon Versio medewerker
    Reactie geplaatst op: 07-12-2017 om 16:52

    Goedemiddag Sjoerd,

    U kunt de PHP versie per domeinnaam instellen, hiervoor volgt u de volgende handleiding: https://www.versio.nl/artikelen/345-hoe-selecteer-ik-een-andere-php-versie

    Na het instellen kunt u diverse php waardes aanpassen, hiervoor klikt op '' Show PHP settings''. Bent u hiermee verder geholpen?

    Vond u dit antwoord nuttig?

  3. Sjoerd Member
    Reactie geplaatst op: 07-12-2017 om 17:00

    Het is gelukt, bedankt!

    Vond u dit antwoord nuttig?

  4. Coralie Member
    Reactie geplaatst op: 12-12-2017 om 11:41

    Hi,
    I'm migrating a wp website but during the process, I need to disable the open_basedir setting in the php.ini file.
    But I can't find the php.ini file.
    Can you help me ?
    Thanks

    Vond u dit antwoord nuttig?

  5. Gavon Versio medewerker
    Reactie geplaatst op: 12-12-2017 om 11:48

    We do not make any changes to the php.ini file.
    You can set the PHP version per domain name. To do this, follow the following manual:
    https://www.versio.uk/articles/347-how-do-i-select-a-different-php-version

    After setting you can adjust various php values, click on '' Show PHP settings ''. Are you further helped with this?

    Vond u dit antwoord nuttig?

  6. Coralie Member
    Reactie geplaatst op: 12-12-2017 om 11:56

    Hey,
    Thanks for your answer but I don't need to change de PHP version.
    To migrate my website I have only 2 options:
    - Disable the open_basedir setting in the php.ini file
    - If the host will not disable, then add the path below to the open_basedir setting in the php.ini
    "/home/coraljt265/domains/coraljt265.265.axc.nl/public_html"

    So if we can't disable the open_basedir, how can I add the mentioned path ?
    Thanks

    Vond u dit antwoord nuttig?

  7. Gavon Versio medewerker
    Reactie geplaatst op: 12-12-2017 om 13:32

    If you click on '' Show PHP settings'' you can add the mentioned path.
    I just added the path for you.

    Vond u dit antwoord nuttig?

  8. Coralie Member
    Reactie geplaatst op: 12-12-2017 om 13:58

    Thank you !

    Vond u dit antwoord nuttig?

  9. Jesper Member
    Reactie geplaatst op: 12-01-2018 om 14:50

    Hi,
    *If you click on '' Show PHP settings'' you can add the mentioned path.
    I just added the path for you.*

    I can't add it. There is no button for adding. How can I do it?
    Or can you do it for me? And do I need to delete it after the migration? (If yes, how to?)

    Vond u dit antwoord nuttig?

  10. Gavon Versio medewerker
    Reactie geplaatst op: 12-01-2018 om 15:34

    Dear Jasper,

    When you click on the field you can add the path. Then you need to save it.

    Vond u dit antwoord nuttig?

  11. Jesper Member
    Reactie geplaatst op: 12-01-2018 om 15:45

    I clicked everywhere...nothing happens. Could you add it please?
    /home/jespevp157/domains/myway-2go.com/public_html

    Vond u dit antwoord nuttig?

  12. Gavon Versio medewerker
    Reactie geplaatst op: 12-01-2018 om 15:55

    Dear Jesper,

    First you need to select a PHP version, Then you click on '' no value'' in PHP settings.
    I just added the path for you.

    Vond u dit antwoord nuttig?

  13. Jesper Member
    Reactie geplaatst op: 12-01-2018 om 15:58

    Thank you, it works!

    Vond u dit antwoord nuttig?