1. Ruud Member

    PHP tijdslimiet verhogen

    Topic geplaatst op: 30-11-2017 om 18:18

    Hoi hoi,

    Ik heb net een nieuw thema geïnstalleerd en deze geeft in zijn analyse aan dat mijn PHP tijdslimiet beter omhoog geschroefd kan worden.
    - Hoe kan ik dit het beste doen?
    - en wat raden jullie voor tijdslimiet aan?

    De melding de ze geven is:
    PHP Time Limit: 30 Current time limit is sufficient for most tasks. However, recommended value is 60. Up to 300 seconds may be required to install the main demo.

    Ze stellen voor om in mijn .htaccess en php.ini wat te veranderen, maar ik wil graag van jullie horen wat de beste optie is. Hun concrete voorstel staat hier hieronder beschreven.

    Groeten,
    Ruud

    https://codex.wordpress.org/Common_WordPress_Errors#Maximum_execution_time_exceeded

    You may receive a message such as "Maximum execution time of 30 seconds exceeded" or "Maximum execution time of 60 seconds exceeded". This means that it is taking to longer for a process to complete and it is timing out. There are a number of ways to fix this error.

    Editing .htaccess

    Make sure you back up .htaccess before you edit it.

    Add the following line to .htaccess:

    php_value max_execution_time 60

    Editing php.ini

    Add the following to php.ini

    max_execution_time = 60

    If you are unsure of how to make these changes, or if you are on shared hosting that prevents you from making them yourself, you should contact your hosting provider and ask them to increase your maximum execution time.

    Reageer
  2. Maurice Versio medewerker
    Reactie geplaatst op: 30-11-2017 om 18:27

    Dat kunt u zelf via uw directadmin paneel (hostingpakket)
    Inloggen in directadmin > domein aanklikken> dan ziet u onderaan bij uw Advanced features "Select PHP version" . Daaronder kunt u een php versie kiezen voor uw site. En via show php settings. en de extensies aan te vinken hier functies voor activeren/aanpassen op uw domein. Ook de php time limit. U kunt deze op 60 zetten dat moet ruim voldoende zijn. Toevoegen via het htaccess bestand werkt dus niet.
    Heeft u nog vragen dan hoor ik het graag?

    Vond u dit antwoord nuttig?

  3. Ruud Member
    Reactie geplaatst op: 30-11-2017 om 18:50

    Thanx Maurice voor je antwoord en de snelle reactie,

    Ik heb het gevonden en aangepast. Ik neem aan dat er even overheen gaat voordat de wijziging is doorgevoerd. Naar het refreshen van de analyse van het thema bleef hij op 30 staan.

    Groeten,
    Ruud

    Vond u dit antwoord nuttig?

  4. Maurice Versio medewerker
    Reactie geplaatst op: 30-11-2017 om 19:04

    Dat kan 30 minuten duren voor dit is verwerkt en actief is.
    Mocht het niet zo zijn kunt u een support ticket aanmaken dan zullen wij dit voor u nazien.

    Vond u dit antwoord nuttig?