1. Radio Westerwolde Member

    Hoge Cpu load /site niet meer bereikbaar

    Topic geplaatst op: 20-03-2012 om 21:32

    Hallo,

    Het gebeurt nogal eens dat onze website "plat"gaat. Vanochtend hadden we dit probleem ook. Al met al is het gelukt op de server (na een minuut of 20 te rebooten)

    Inloggen via SSH verliep net zo dramatisch. Eenmaal ingelogd kon ik met het commando "top" zien dat erg veel processen van httpd geopend waren.
    Ook een process van Mysqld had 102% CPu in gebruik.

    Kan dit duiden op een DDoS aanval, of moet ik het ergens anders zoeken.
    Is Apache en MySql nog te tunen?

    Hebben jullie nog andere tips om dit te voorkomen?

  2. Reshad Versio medewerker
    Reactie geplaatst op: 20-03-2012 om 22:12

    Hoi J de Vries,

    Ik denk niet dat dit een DDOS aanval is, maar dat je website simpelweg een foutje heeft ergens. Je MySQL database(s) overbelast(en) de server.

    Draai de volgende commando wanneer je bent ingelogd in SSH:
    alias mysqlproc='. /usr/local/directadmin/conf/mysql.conf; mysqladmin -u $user --password=$passwd processlist'

    Draai daarna:
    mysqlproc

    Je ziet dan exact welke processen er draaien.

    Succes!

    Vond u dit antwoord nuttig?

  3. RayHammer Member
    Reactie geplaatst op: 23-03-2012 om 14:06

    Welke versie mysql gebruik je? Alles up to date?

    Vond u dit antwoord nuttig?

  4. Radio Westerwolde Member
    Reactie geplaatst op: 24-03-2012 om 22:56

    Versie MySQL 5.1.61. Ik had via custombuild al gecontroleerd op de laaste versie. Dit bleek de laatste versie te zijn, of toch niet?

    Vond u dit antwoord nuttig?

  5. RayHammer Member
    Reactie geplaatst op: 25-03-2012 om 12:06

    Nee dat is niet de laatse versie. De laatse nieuwe is 5.5.21

    Ga naar cd /usr/local/directadmin/custombuild
    en open options.config en zet bij mysql 5.5


    Dan sluit je mc af en typ je het volgende in.

    ./build update
    ./build clean
    ./build versions
    ./build mysql

    Nadat mysql klaar is moet je nog even php herinstallen.

    ./build php n

    Thats it

    Vond u dit antwoord nuttig?

  6. Radio Westerwolde Member
    Reactie geplaatst op: 26-03-2012 om 00:50

    MySql gëupdatet naar versie 5.5.21. Echter vanavond liep de load en de swap weer behoorlijk op. via top zag ik dat er behoorlijk wat httpd sessie open.

    Ik begin nu te twijfelen of mysql of apache is die het veroorzaakt.

    Op de server draaien twee site 1 productie (wordpress) en 1 test site welke gereed wordt gemaakt op de huidige productiesite op te volgen.

    Beide website zijn gebouwd in Wordpress. De productie draait nog op 2.97 (volgens mij) en de test site draait inmiddels op de laatste versie 3.

    De productiesite is wel een druk bezochte site. Is hier apache nog op te tunen???

    Vond u dit antwoord nuttig?

  7. RayHammer Member
    Reactie geplaatst op: 26-03-2012 om 11:20

    Druk bezochte site? Om hoeveel unieke bezoekers gaat het per dag.

    Plus wat draai je allemaal op die server? CLI of CGI?

    Vond u dit antwoord nuttig?

  8. Radio Westerwolde Member
    Reactie geplaatst op: 26-03-2012 om 22:43

    Het aantal unieke bezoekers heb ik opgevraagd bij de website bouwers. Hier hoop nog antwoordt op te krijgen.

    Na oplevering door Versio inclusief Diret Admin heb ik CSF Firewaal geïnstalleerd, php geupdatet naar 5.3 MySQL geupdatet naar 5.5 Midnight Commander en htop geinstalleerd. Verder geen extra's geinstalleerd.

    CLI of CGI?

    Volgens mij CLI (in de options.conf staat bij php5_cli=yes. Ik neem aan dat het bij installatie in CLI mode is gezet)

    Vond u dit antwoord nuttig?

  9. Un1x Member
    Reactie geplaatst op: 19-10-2012 om 11:45

    Misschien is het verstandig om de logfiles te bekijken. Die van httpd en die van mysql, en vervolgens een monitoring in te stellen op alle processen die draaien.

    Daarna ontvang je netjes het antwoord op dit probleem.

    Vond u dit antwoord nuttig?