1. Nicolas Claeys Member

    VPS Load

    Topic geplaatst op: 29-02-2012 om 17:29

    deze morgen kreeg ik dit bericht:

    This is an automated message notifying you that the 5 minute load average on your system is 11.77.
    This has exceeded the 10 threshold.

    One Minute - 26.9
    Five Minutes - 11.77
    Fifteen Minutes - 4.56

    top - 01:17:44 up 13:12, 0 users, load average: 26.43, 11.93, 4.65
    Tasks: 98 total, 6 running, 92 sleeping, 0 stopped, 0 zombie
    Cpu(s): 0.7%us, 0.2%sy, 0.0%ni, 92.2%id, 6.9%wa, 0.0%hi, 0.0%si, 0.0%st
    Mem: 3094632k total, 1208448k used, 1886184k free, 0k buffers
    Swap: 0k total, 0k used, 0k free, 0k cached

    Deze namiddag merkte ik op dat de server / site weer aan het verslomen was, en inderdaad ik zat weer met een load van 33. Kan mij hier iemand in adviseren en begeleiden om dit opgelost te krijgen?

  2. Nicolas Claeys Member
    Reactie geplaatst op: 29-02-2012 om 17:30

    Ik krijg de server momenteel niet gebood ook

    Vond u dit antwoord nuttig?

  3. zwerfkat Member
    Reactie geplaatst op: 29-02-2012 om 21:57

    Inloggen via SSH, gebruik commando's zoals ps en pstree om te zien waardoor de hoge load wordt veroorzaakt. Of atop/htop installeren. Verder goed in de log files kijken, wordt er excessief veel mail verstuurd, heb je zeer hoge bezoekers aantallen, etc.

    Vond u dit antwoord nuttig?

  4. RayHammer Member
    Reactie geplaatst op: 01-03-2012 om 08:17

    Iotop,htop en atop kun je veel uit halen.

    Kopie eens de automated message compleet hier als je wilt, normaal staat in de automated message waarom de load hoog was.

    Vond u dit antwoord nuttig?

  5. Nicolas Claeys Member
    Reactie geplaatst op: 01-03-2012 om 10:18

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    7766 mysql 15 0 142m 16m 4756 S 9.4 0.5 1:26.23 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --log-error=/var/lib/mysql/vps24110.a.nl.err --pid-file=/var/lib/mysql/vps24110.a.nl.pid
    13902 apache 16 0 52716 37m 3652 S 8.3 1.3 0:00.91 /usr/sbin/httpd -k start -DSSL
    13905 apache 16 0 52716 38m 3652 R 8.3 1.3 0:00.92 /usr/sbin/httpd -k start -DSSL
    13862 apache 15 0 52716 31m 3652 S 7.1 1.0 0:00.93 /usr/sbin/httpd -k start -DSSL
    13873 apache 16 0 52732 35m 3448 R 4.7 1.2 0:00.83 /usr/sbin/httpd -k start -DSSL
    13892 apache 15 0 52716 38m 3652 R 4.7 1.3 0:01.00 /usr/sbin/httpd -k start -DSSL
    13872 apache 16 0 52708 35m 3652 R 2.4 1.2 0:01.07 /usr/sbin/httpd -k start -DSSL
    13904 apache 16 0 47292 33m 3256 D 1.2 1.1 0:00.69 /usr/sbin/httpd -k start -DSSL
    13907 apache 16 0 52532 37m 3284 D 1.2 1.2 0:00.62 /usr/sbin/httpd -k start -DSSL
    13909 apache 16 0 51776 37m 3316 D 1.2 1.2 0:00.62 /usr/sbin/httpd -k start -DSSL
    13999 apache 15 0 51784 37m 3636 D 1.2 1.2 0:00.57 /usr/sbin/httpd -k start -DSSL
    16287 apache 16 0 31388 17m 3060 D 1.2 0.6 0:00.10 /usr/sbin/httpd -k start -DSSL
    1 root 15 0 2160 656 568 S 0.0 0.0 0:00.00 init [3]
    3076 apache 16 0 53004 35m 3940 D 0.0 1.2 0:02.81 /usr/sbin/httpd -k start -DSSL
    5618 apache 15 0 52856 37m 3580 D 0.0 1.2 0:02.37 /usr/sbin/httpd -k start -DSSL
    5633 apache 16 0 52900 38m 3824 D 0.0 1.3 0:02.71 /usr/sbin/httpd -k start -DSSL
    5635 apache 16 0 53104 32m 3776 D 0.0 1.1 0:02.41 /usr/sbin/httpd -k start -DSSL
    5911 root 15 -4 2264 536 344 S 0.0 0.0 0:00.00 /sbin/udevd -d
    6056 root 15 0 32700 564 460 S 0.0 0.0 0:00.06 brcm_iscsiuio
    7245 apache 16 0 53392 29m 3872 D 0.0 1.0 0:05.45 /usr/sbin/httpd -k start -DSSL
    7503 root 18 0 1816 568 472 S 0.0 0.0 0:00.11 syslogd -m 0
    7606 root 16 0 3492 708 540 S 0.0 0.0 0:00.00 /usr/sbin/dovecot
    7619 dovecot 15 0 6708 1548 1408 S 0.0 0.1 0:00.00 dovecot/pop3-login


    ================================
    Automated Message Generated by DirectAdmin
    From: Message System


    Ik vermoed intussen dat ik een script heb die de oorzaak was, ik heb deze uitgezet en nu loopt alles lekker.

    Het is een performance script voor WP, W3 total cache, en ik vermoed dat die de verhuis van de site niet zo goed heeft doorstaan, heb hem momenteel verwijdert en alles loopt goed. Zou het kunnen?

    Vond u dit antwoord nuttig?

  6. RayHammer Member
    Reactie geplaatst op: 01-03-2012 om 15:37

    Apache is de load veroorzaker. Welke node heb je, een 32bit of 64bit? Installeer htop en atop eens en zet het kopie het verslag hier aub.

    Vond u dit antwoord nuttig?

  7. RayHammer Member
    Reactie geplaatst op: 01-03-2012 om 15:39

    De cache zak onder apache user gedraaid hebben. Je kan die veranderen op je naam in DirectAdmin.

    Vond u dit antwoord nuttig?

  8. Nicolas Claeys Member
    Reactie geplaatst op: 01-03-2012 om 16:36

    Wat moet ik juist aanpassen in DA?

    Vond u dit antwoord nuttig?

  9. Nicolas Claeys Member
    Reactie geplaatst op: 01-03-2012 om 17:03

    Ik werk trouwens met CentOS 5.5 32bit

    Vond u dit antwoord nuttig?

  10. Nicolas Claeys Member
    Reactie geplaatst op: 01-03-2012 om 18:21

    Screenshot van htop http://tinypic.com/r/ohqwjr/5

    Vond u dit antwoord nuttig?

  11. RayHammer Member
    Reactie geplaatst op: 02-03-2012 om 09:16

    Weinig aan te zien dan enkel wat apache. Ik zou Php 5.3.10 erop zetten met suPHP CGI. Dan is het nog makkelijker om te zien welk account er zo veel load gebruik.

    Vond u dit antwoord nuttig?

  12. Nicolas Claeys Member
    Reactie geplaatst op: 02-03-2012 om 15:36

    Als ik een andere versie van PHP erop zet is dat zonder risico voor mijn site? En hoe kan ik PHPmyadmin upgraden? nu staat er nog 2.11.11.3 op

    Vond u dit antwoord nuttig?

  13. RayHammer Member
    Reactie geplaatst op: 03-03-2012 om 09:21

    Nee kan geen kwaad suPHP. Het zorgt ervoor dat je geen bestanden op 777 meer kan zetten en dat je onder suPHP draaid in plek van Apache.

    phpmyadmin upgraden doe je zo:

    cd /usr/local/directadmin/custombuild
    ./build update
    ./build clean
    ./build phpmyadmin

    Thats it

    Vond u dit antwoord nuttig?

  14. RayHammer Member
    Reactie geplaatst op: 03-03-2012 om 09:46

    Wat voor website staat erop? Ik wil best even kijken waar de load vandaan komt voor je. Vraag hiervoor mij e-mail bij Versio.

    Vond u dit antwoord nuttig?

  15. Nicolas Claeys Member
    Reactie geplaatst op: 03-03-2012 om 10:42

    Zo heb alle updates netjes kunnen uitvoeren. Hopelijk helpt dat al wat. Alvast heel erg bedankt voor de hulp! Super!

    de site die draait is deze: http://www.a-n-v.be

    Vond u dit antwoord nuttig?

  16. RayHammer Member
    Reactie geplaatst op: 03-03-2012 om 13:38

    Mooie website. Maar ook wel die veel load kan gebruiken.

    Succes verder

    Vond u dit antwoord nuttig?

  17. Nicolas Claeys Member
    Reactie geplaatst op: 20-03-2012 om 22:46

    Het ging een tijdje goed, maar nu heb ik een aantal dagen weer last van hoge loads.
    http://tinypic.com/r/2llzz0x/5

    Er zijn geen extra scripts toegevoegd aan de site, en zit een beetje met de handen in het haar. Een aantal weken lang liep alles goed. En nu plots weer die problemen.
    Kan iemand me helpen?

    Vond u dit antwoord nuttig?

  18. Nicolas Claeys Member
    Reactie geplaatst op: 21-03-2012 om 19:27

    Deze avond weer zware problemen, ik zit echt met de handen in het haar...

    http://tinypic.com/r/w6qo2a/5

    Vond u dit antwoord nuttig?

  19. zwerfkat Member
    Reactie geplaatst op: 22-03-2012 om 10:16

    Als ik naar je htop screenshot kijk, zie ik veel processen met status "Waiting" (D) en een geheugen dat vol zit. Het lijkt er op dat je disk I/O vertraagd/gestopt is waardoor er vele processen ontstaan die staan te wachten en waardoor je geheugen vol loopt. Wat geeft het commando "top" aan bij %wa?

    Controleer eens of je nog genoeg schijfruimte hebt. Het kan een script zijn dat per ongeluk excessief veel disk I/O gebruikt, maar het kan ook een probleem met de VPS server zelf zijn, daarvoor moet je Versio raadplegen.

    Vond u dit antwoord nuttig?

  20. Nicolas Claeys Member
    Reactie geplaatst op: 22-03-2012 om 11:30

    Heel erg bedankt voor je reactie, nu weet ik in welke richting ik moet zoeken. Ik heb intussen een ander cache script geïnstalleerd, ik vermoed dat het probleem van daar komt.

    Zodra ik meer weet kom ik er hier op terug met de info die je vraagt. Tnx!

    Vond u dit antwoord nuttig?

  21. Nicolas Claeys Member
    Reactie geplaatst op: 22-03-2012 om 19:52

    Vandaag weer twee keer prijs gehad

    http://tinypic.com/r/x44poi/5 (htop)
    http://tinypic.com/r/34ypdvp/5 (top)

    Schijfruimte is er meer dan voldoende ik gebruik slecht 5GB van de 300GB

    Vond u dit antwoord nuttig?

  22. Wesley Member
    Reactie geplaatst op: 22-03-2012 om 20:34

    Probeer eens top d1c en plaats hier een prnt screen van.

    Vond u dit antwoord nuttig?

  23. Nicolas Claeys Member
    Reactie geplaatst op: 22-03-2012 om 20:59

    http://tinypic.com/r/jqi5wn/5

    Hij is nu al voor de derde keer down vandaag

    Vond u dit antwoord nuttig?

  24. Nicolas Claeys Member
    Reactie geplaatst op: 23-03-2012 om 07:18

    Intussen door versio offline gehaald... Dit terwijl ik net om support vroeg...

    Vond u dit antwoord nuttig?

  25. zwerfkat Member
    Reactie geplaatst op: 23-03-2012 om 09:17

    Precies wat ik dacht, een %wa (waiting for i/o) boven de 90%. Dat betekent waarschijnlijk dat er niet snel genoeg van disk kan worden gelezen of geschreven, om welk reden dan ook.

    Vond u dit antwoord nuttig?

  26. Nicolas Claeys Member
    Reactie geplaatst op: 23-03-2012 om 09:18

    Ligt de fout dan bij mij of bij de VPS?

    Vond u dit antwoord nuttig?

  27. zwerfkat Member
    Reactie geplaatst op: 23-03-2012 om 13:19

    Dat is niet zomaar 123 te zeggen waar het probleem ligt, daarvoor zou ik maar even contact opnemen met Versio, zij weten beter waar de limieten liggen en hebben wellicht een monitor systeem waarop ze kunnen zien of er overmatig disk I/O plaats vindt.

    Vond u dit antwoord nuttig?

  28. Nicolas Claeys Member
    Reactie geplaatst op: 23-03-2012 om 13:28

    MJa, ze hebben hem weer online gezet, en nu, zonder mij iets te laten weten en voor ik goed en wel alles kan doornemen scripts kan gaan uitzetten. Zetten ze hem weer offline.

    Pff zo geraak ik er ook niet uit

    Vond u dit antwoord nuttig?

  29. Nicolas Claeys Member
    Reactie geplaatst op: 23-03-2012 om 14:25

    Geen reactie van versio, kan men zeggen dat men ermee bezig is ofzo?

    Vond u dit antwoord nuttig?

  30. Nicolas Claeys Member
    Reactie geplaatst op: 23-03-2012 om 21:06

    Hoe komt het dat ik na vandaag plots meer 2CPU's zie?
    http://tinypic.com/r/10h6ovn/5

    Vond u dit antwoord nuttig?

  31. RayHammer Member
    Reactie geplaatst op: 25-03-2012 om 12:16

    Je had een 4 core en nu een 2 core zoals ik zie bij htop. Meer core,s is niet altijd beter hoor. Maar voor je load probleem zul je iemand moeten zoeken die even kan kijken, zoals de helpdesk nog eens.

    Vond u dit antwoord nuttig?

  32. RayHammer Member
    Reactie geplaatst op: 25-03-2012 om 12:25

    Ik wil best even kijken gratis als dat van Versio mag. Vraag aan Versio mijn e-mail.

    Vond u dit antwoord nuttig?

  33. Nicolas Claeys Member
    Reactie geplaatst op: 25-03-2012 om 16:38

    Toch vind ik het eigenaardig dat ik nu plots maar 2 cores zie. De load lijkt nu al twee dagen onder controle.

    Ik heb een poging gedaan om via Versio vorige week je mail adres te krijgen maar ik heb bot gevangen. Ik moet "zelf het probleem vinden zonder andere klanten hierbij tot overlast te zijn". Versio wil niet helpen. Een zeer spijtige zaak vind ik persoonlijk, zeker als je zo handelt met een goede klant.

    Vond u dit antwoord nuttig?

  34. RayHammer Member
    Reactie geplaatst op: 26-03-2012 om 11:29

    Dat is inderdaad jammer dat we elkaar zo niet kunnen helpen. Je kan namelijk veel van elkaar leren op dat gebied.

    Nu vraag ik me wel af waarom je nu maar 2 cores hebt terwijl je eerst 4 cores had. Heeft Versio je dit nog niet uigelegt? Dat zou natuurlijk wel moeten als je wilt weten wat ze met je server aan het doen zijn.

    Vond u dit antwoord nuttig?

  35. Peter Bin Member
    Reactie geplaatst op: 26-03-2012 om 22:39

    @RayHammer op 02-03-2012 om 09:16

    Je kan beter Mod_Ruid2 installeren ipv SuPHP.
    Mod_Ruid2 werkt sneller en is veiliger.

    Vond u dit antwoord nuttig?

  36. RayHammer Member
    Reactie geplaatst op: 27-03-2012 om 13:43

    @Peter Heb je daar ergens een tutorial voor?

    Vond u dit antwoord nuttig?