1. imperium Member

    Httpd process is stopped

    Topic geplaatst op: 24-02-2012 om 01:35

    Beste mensen,

    3 dagen lang is mijn website onbereikbaar geweest omdat "httpd process is stopped" nu heeft hij het sinds gister avond weer gedaan, maar zit ik nu met hetzelfde probleem.

    De support wilde mij gisteren niet helpen omdat ik geen service contract had en heb ik het op een forum gevraagt waar iemand het binnen paar minuten had gefixed.
    Hij zei het volgende:
    Hij bleek dat ssl_mutex bestandje niet aan te kunnen maken omdat het al bestond.
    Normaal gesproken zou de server dat zelf moeten opruimen, maar nu kon ie dat blijkbaar niet. Ik heb het bestandje gerenamed naar .bak en apache herstart.
    Ik snap niet goed dat je eigen hoster die niet direct oplost. http plat betekent bij ons dat een klant zijn server op zijn minst problemen heeft...

    Weet iemand hoe het kan dat dit weer gebeurd en hoe ik dit kan voorkomen?

    mvg, Willem

  2. Reshad Versio medewerker
    Reactie geplaatst op: 24-02-2012 om 08:04

    Hoi Willem,

    Zonder support contract wordt er inderdaad geen technische ondersteuning gegeven. Dus dan moet je het bijvoorbeeld zelf oplossen via Google: http://trixboxer.com/blog/error-17file-exists-cannot-create-sslmutex-with-file-usrlocalapachelogsssl_mutex/

    Vond u dit antwoord nuttig?

  3. Reshad Versio medewerker
    Reactie geplaatst op: 24-02-2012 om 08:06

    (of via forums zoals deze natuurlijk)

    Vond u dit antwoord nuttig?

  4. RdV Member
    Reactie geplaatst op: 05-03-2012 om 11:46

    Toen ik nog een VPS had, zag ik dit ook zeer regelmatig gebeuren. Ik ben er nooit achter gekomen, maar mijn vermoeden was een resource issue (te weinig geheugen en een tijdelijke httpd memory spike, in combinatie met een VPS die niet tijdig genoeg IO cycles krijgt). Nooit een log kunnen vinden die een indicatie gaf, maar IO was op piek tijden altijd wel langzaam.

    Ik heb het opgelost door een cronjob elke minuut te laten lopen om de httpd status te controleren, en indien dood, opnieuw te laten starten.

    Als mijn vermoeden correct is, is het "eenvoudig" op te lossen door te upgraden naar een betere VPS plan. Betreffende IO resources, doe je het beste om een expert VPS te verkiezen boven een starter VPS. Ik had de instap starter VPS. Ik heb uiteindelijk gekozen voor een dedicated server, en tja, daar gaat httpd nooit meer onderuit, ongeacht de load.

    Vond u dit antwoord nuttig?

  5. RayHammer Member
    Reactie geplaatst op: 05-03-2012 om 15:43

    @imperium Je bent zelf verantwoordelijk voor je server als je de service ondersteuning niet hebt.

    Vond u dit antwoord nuttig?

  6. mike Member
    Reactie geplaatst op: 10-04-2012 om 23:30

    Beste Willem ,zou je de exacte stappen kunnen uitleggen welke je heb doorlopen om dit te herstellen?.Ik denk namelijk dat ik hetzelfde probleem heb.

    Vond u dit antwoord nuttig?

  7. Un1x Member
    Reactie geplaatst op: 08-05-2012 om 12:22

    Wat ook vaak het probleem kan zijn is dat de hostname/servername veranderd is, hier reageert de httpd dan niet meer op. Om dit overigens na te kijken kun je de httpd log files benaderen.

    Vond u dit antwoord nuttig?

  8. zwerfkat Member
    Reactie geplaatst op: 08-05-2012 om 13:21

    Zelf heb ik dit ssl_mutex gerelateerde probleem onlangs op mijn VPS gehad:
    http://carlosrivero.com/fix-apache---no-space-left-on-device-couldnt-create-accept-lock

    Via dit commando kun je controleren of er te grote hoeveelheden semaphoren door apache in gebruik zijn:

    ipcs -s | grep apache

    Na het verwijderen van de semaphoren werkte httpd weer:

    ipcs -s | grep apache | awk ' { print $2 } ' | xargs ipcrm sem

    Vond u dit antwoord nuttig?