1. Alain Simons Member

    Move_uploaded_file() werkt niet

    Topic geplaatst op: 14-12-2015 om 20:32

    Ik krijg geen bestanden geupload.

    move_uploaded_file($_FILES[“photo”][“tmp_name”], “../relative_path”)
    → geeft (altijd) false terug

    Het relatieve path klopt. Ik heb voor de zekerheid ook alle rechten gegeven (777) voor zowel de folder waar het php bestand zit die de upload verwerkt als voor de folder waar de upload terecht moet komen.

    De waarde van $_FILES[“photo”][“tmp_name”] = “/tmp/RANDOMSTUFF”

    De website stond vroeger op een andere (niet Versio) server en werkte. Enkel de ftp en database gegevens zijn aangepast. Buiten move_uploaded_file() blijkt alles gewoon te werken.


    Kan iemand mij helpen? Waarom werkt dit niet?

  2. Dutchwaters Member
    Reactie geplaatst op: 16-12-2015 om 23:37

    Probeer anders eens ipv het relatieve pad, het absolute pad naar de map: /home/DAgebruikersnaam/domains/domein.tld/public_html/upload-map

    Vond u dit antwoord nuttig?

  3. jordivn Member
    Reactie geplaatst op: 22-12-2015 om 14:05

    Is het bestand wel goed geupload naar de tmp map?
    In de FILES array worden ook eventuele fouten meegegeven.
    Zelf maak ik altijd gebruik van $_SERVER["DOCUMENT_ROOT"] . "pad naar map /"
    Werkt bij mij altijd.

    Vond u dit antwoord nuttig?

  4. Mathijs Mos Member
    Reactie geplaatst op: 22-12-2015 om 15:22

    Hallo Wouter,

    Is het reeds gelukt? Zo niet, dan kunt u even een ticket aanmaken via het klantenpaneel.

    Bij voorbaat dank.

    Vond u dit antwoord nuttig?