1. MartijnBouwman Member

    Multisite WordPres met subdomein

    Topic geplaatst op: 09-02-2012 om 12:28

    Goedendag,

    Ik ben reeds sinds gister bezig om een multisie WordPress aan de gang te krijgen op basis van subdomein. Helaas wil dit maar niet lukken.

    Net is het wel gelukt (binnen 5 minuten tijd) om multisite op te zetten met subdirectories. Ik heb dus het idee dat het niet aan WordPress ligt.

    Stappen ondernomen:
    - Subdomein aangemaakt via DirectAdmin (ook zonder geprobeerd om te zien of WordPress zelf routeert)
    - Wildcard op DNS beheer aangezet (*.domeinnaam.nl, A record)
    - WordPress via Installatron geïnstalleerd
    - Tutorial uitgevoerd van WordPress (http://wp.tutsplus.com/tutorials/using-wordpress-multisite-a-network-of-websites-at-your-fingertips/)

    Nu krijg ik het dus voor subdirs wel snel werkend, maar subdomains totaal niet... wat doe ik verkeerd of vergeet ik?

    groet,
    Martijn.

  2. Jan Cairo Member
    Reactie geplaatst op: 09-02-2012 om 20:54

    Hallo,

    Ik ben daar ook mee bezig. Eerst zelf gedaan, wat ingewikkeld was omdat ik niets begreep van dns-servers wijzigen e.d. Toen via Installatron, wat supermakkelijk ging. Alleen heb ik nu het probleem dat ik subdomeinen heb aangemaakt maar dat WordpressMulti een directory laat zien.
    In plaats van http://binnen24uurbezorgd.nl/speelgoed/ zou er moeten staan speelgoed.binnen24uurbezorgd.nl
    Iemand een idee?

    Vond u dit antwoord nuttig?

  3. Reshad Bashir Versio medewerker
    Reactie geplaatst op: 10-02-2012 om 00:19

    Hoi Martijn en Jan,

    Is het niet zo dat je even wildcard DNS aan moet laten zetten door de helpdesk? Anders werkt het subdomein systeem niet. Wildcard DNS is dat iedere subdomeinnaam van een domeinnaam naar de index.php van de domeinnaam gaat, de .htaccess samen met de PHP verwerkt dit dan verder.

    Vond u dit antwoord nuttig?

  4. MartijnBouwman Member
    Reactie geplaatst op: 10-02-2012 om 09:32

    Hoi Reshad,

    Dank voor je antwoord, ik heb het inmiddels bij de helpdesk neergelegd in de hoop dat dit het oplost. Ik zal het in dit topic nog even terugkoppelen als dat de oplossing was.

    Vond u dit antwoord nuttig?

  5. MartijnBouwman Member
    Reactie geplaatst op: 10-02-2012 om 13:42

    Het was inderdaad op te lossen door via de supportdesk de wildcard DNS aan te zetten. Heel erg blij dat het is opgelost :)

    Vond u dit antwoord nuttig?

  6. adp Member
    Reactie geplaatst op: 20-09-2012 om 14:41

    Wie kan me verder helpen? Ik krijg mijn WP Multisite niet goed draaiend...

    De installatie is door Installatron vanuit DirectAdmin gedaan en ik gebruik de plugin WordPress MU Domain Mapping.

    De helpdesk heeft gisteren een wildcard aangemaakt voor http://www.(site1).nl. Deze domeinnaam moet gekoppeld worden aan http://www.(multisite).nl/(site1).

    Andersom werkt het via de plugin al wel. De oorspronkelijke URL http://www.(multisite).nl/(site1) verwijst wordt al gemapt naar http://www.(site1).nl.

    Vond u dit antwoord nuttig?

  7. Jaccom Internet Member
    Reactie geplaatst op: 07-02-2013 om 20:50

    Zijn er ook mensen die dit op een shared hosting voor elkaar hebben en daarbij gebruik maken van de domain mapping plugin om subdomeinen aan domeinnamen te linken ?

    Ben wel klaar met het 10x moeten uploaden van een theme naar elke afzonderlijke website nadat ik wat wijzigingen heb aangebracht, dus ik hoor het graag.

    Vond u dit antwoord nuttig?