1. Jeroen Schilt Member

    Wordpress update 4.2 mislukt

    Topic geplaatst op: 27-04-2015 om 11:33

    Dag,

    Een vraag.. de update op van Wordpress naar versie 4.2 milsukt op de Versio server.
    We hebben ook een andere provider en daar draait de automatische update prima.
    Heeft iemand een idee, tip of advies voor me?

    Het betreft de volgende foutmelding:
    /public_html/wp/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: Permission denied in:
    public_html/wp/wp-admin/includes/class-wp-filesystem-direct.php on line 231

    De update kon niet worden geïnstalleerd omdat we sommige bestanden niet konden kopiëren. Dit komt meestal door inconsistente bestandsrechten.: wp-admin/includes/update-core.php
    Installatie is mislukt

    Bij voorbaat dank voor het meedenken!

    Vriendelijke groet,
    Jeroen

  2. Fabien Daniel Versio medewerker
    Reactie geplaatst op: 27-04-2015 om 16:45

    Hallo, u kunt de website draaien op PHP 5.4, voeg dit toe helemaal bovenaan het .htaccess bestand:

    <FilesMatch ".php$">
    AddHandler x-httpd-php54 .php
    </FilesMatch>

    Vervolgens alle mappen op 755 instellen en bestanden op 644. Mocht het niet lukken kunt u een support ticket aanmaken via het klantenpaneel en de DirectAdmin username en het domein vermelden.

    Vond u dit antwoord nuttig?

  3. Jeroen Schilt Member
    Reactie geplaatst op: 28-04-2015 om 14:19

    Dag Fabien,

    Dank, ik ga op onderzoek!

    Vriendelijke groet,
    Jeroen

    Vond u dit antwoord nuttig?

  4. Jeroen Schilt Member
    Reactie geplaatst op: 28-04-2015 om 14:23

    Vraag...
    Waar kan ik het .htaccess bestand vinden?
    Bij onze andere provider staat het in de map van de index, site, maar hier (nog) niet.

    Vriendelijke groet,
    Jeroen

    Vond u dit antwoord nuttig?

  5. Gerald Van Wattum Versio medewerker
    Reactie geplaatst op: 28-04-2015 om 14:35

    Deze staat in de map

    /domains/uwdomeinnaam.nl/public_html

    Als deze hier nog niet aanwezig is dan zult u het bestand moeten aanmaken en daarin dus de code moeten plaatsen.

    Vond u dit antwoord nuttig?

  6. Ashwin Brouwer Member
    Reactie geplaatst op: 28-04-2015 om 18:01

    Ik heb hetzelfde probleem, alle stappen gevolgd en nog werkt de update niet. Wat kan ik doen?

    Vond u dit antwoord nuttig?

  7. czijl Member
    Reactie geplaatst op: 28-04-2015 om 18:27

    Ja hoor weer een update en kan na het updaten weer niet in de wp-admin
    Waarom is dit toch zo moeilijk en moet je allerlei technische dingen zelf regelen
    Is er ergens standaard een handleiding voor dit soort dingen als het niet voor je geregeld word duurd iedere x een week of meer voor alles weer werkt
    heel graag weer wat hulp
    Carla

    Vond u dit antwoord nuttig?

  8. Jeroen Schilt Member
    Reactie geplaatst op: 28-04-2015 om 18:38

    @ Gerald..

    Dank, ik ga aan de slag.

    Vriendelijke groet,
    Jeroen

    Vond u dit antwoord nuttig?

  9. Jeroen Schilt Member
    Reactie geplaatst op: 28-04-2015 om 21:34

    @Carla en Ashwin..
    Ik hoop dat jullie eruit komen met eenvoud... en ik ook.. :)
    Groet,
    Jeroen

    Vond u dit antwoord nuttig?

  10. Jeroen Schilt Member
    Reactie geplaatst op: 28-04-2015 om 21:47

    Helaas...
    Uitpakken update…

    Uitgepakte bestanden verifiëren…
    Voorbereidingen gestart om installatie te starten naar de laatste versie…
    Voorbereidingen gestart om installatie te starten naar de laatste versie…

    vervolgens..
    Internal Server Error
    en onmogelijk om nog in te loggen.
    Ik zal een helptopic aanmaken..

    Groet,
    Jeroen

    Vond u dit antwoord nuttig?

  11. Gerald Van Wattum Versio medewerker
    Reactie geplaatst op: 28-04-2015 om 21:55

    @ Jeroen

    Zie dat je Wordpress installatie in de map /wp staat. In dat geval dient u de htaccess aan te passen in de map

    /domains/uwdomeinnaam.nl/public_html/wp/

    Vond u dit antwoord nuttig?

  12. Jeroen Schilt Member
    Reactie geplaatst op: 28-04-2015 om 22:44

    Gedaan en wederom een.. Internal Server Error en niet meer kunnen inloggen bij WP.

    Vriendelijke groet,
    Jeroen

    Vond u dit antwoord nuttig?

  13. Roeland Topée Member
    Reactie geplaatst op: 29-04-2015 om 11:28

    Mij lukt het ook niet upgrades vanuit het WP dashboard te doen. Het zou fijn zijn als Versio het wat makkelijker maakte voor niet technische mensen.

    De oplossing die voor mij werkt is inloggen in DirectAdmin, dan een van mijn domeinnamen aanklikken onderaan naar de geinstalleerde apllicaties. Vanaf die pagina kan ik wel upgraden. Er is een (veilige) versie voorgeselecteerd, maar je kunt deze wijzigen in de laatste versie.

    Vond u dit antwoord nuttig?

  14. Chris Bogers Member
    Reactie geplaatst op: 29-04-2015 om 14:18

    Perfect. met het wijzigen van PHP5.4 code en de file permissions check doet hij het prima!

    Vergeet niet mensen, WordPress is niet bedoeld voor amateurs..... je moet wel een beetje verstand van zaken hebben.

    Vond u dit antwoord nuttig?

  15. Jeroen Schilt Member
    Reactie geplaatst op: 29-04-2015 om 15:49

    @ Roeland Topée
    Dankje voor je delen van dat wat voor je werkte! ... werkt gelukkig voor mij ook :)

    Vriendelijke groet,
    Jeroen

    Vond u dit antwoord nuttig?

  16. Jeroen Schilt Member
    Reactie geplaatst op: 29-04-2015 om 15:54

    En... Versio - zo las ik in mijn helpticket - had ook een aanpassing gemaakt.
    Al met al ben ik perfect geholpen!
    Vriendelijke groet,
    Jeroen

    Vond u dit antwoord nuttig?

  17. Ashwin Brouwer Member
    Reactie geplaatst op: 29-04-2015 om 18:32

    Voor domein 1 is het gelukt en voor domein 2 helaas niet.
    Voor domein 2 heb ik uiteindelijk een handmatige update gedaan met behulp van FileZilla. Dat werkte prima voor mij!

    Vond u dit antwoord nuttig?