1. Quinten Stroobants Stroobants Member

    Li Werkt niet op http (geen httpS

    Topic geplaatst op: 14-04-2015 om 11:42

    Help. De titel zegt het.
    Op http://blazex.eu werken de <li></li>'s niet. Maar bij HTTPS wel, maar daar geeft hij dan onveilige website aan...

  2. Sander Keuzenkamp Member
    Reactie geplaatst op: 19-04-2015 om 12:49

    Ik ben ook slechts een klant hoor, maar u kan het volgende proberen:

    <li><span> test 1 </span></li>
    <li><span> test 2 </span></li>

    Vond u dit antwoord nuttig?

  3. Rick Wolthuis Member
    Reactie geplaatst op: 21-04-2015 om 22:33

    Ik denk dat je omgeving als volgt is;

    Je wilt graag een HTTPS (beveiligde verbinding) voor je website, om de data encrypted te versturen en daardoor veiliger maakt tegen bijv. wire sniffers.

    Nu zeg je dat je styling wel werkt op je HTTP verbinding, maar niet op je HTTPS. Je styling heeft over het algemeen niks te maken met het protocol (HTTP of HTTPS) gebruikt. De zelfde data komt van de server aan, alleen het verschil is de manier waarop. De browsers van je bezoekers bouwen vervolgens de website op.

    Als ik even in je bron kijk, zie ik dat je externe CSS files ophaalt waar je styling in geplaatst is. Niks mis mee! Wat ik daarbij wel merk is dat je ze ophaalt van een HTTP verbinding, terwijl je verbonden bent met een HTTPS verbinding naar je website. Dit is een beveiligings risico, en daarom blokkeren browsers vaak deze content.

    Hoe los je dit nou op?
    Zorg ervoor dat ALLE content van een (geldige!) HTTPS verbinding af komen. Ik zou je aan raden om je statische bestanden op je HTTPS gedeelte van je website te plaatsen. Als je die vanaf je HTTP verbinding opent, is er niks aan de hand. Het ophalen van 'veilige' content over een 'onveilige' verbinding is geen probleem. Het ophalen van 'onveilige' content over een 'veilige' verbinding is dus wel een probleem.

    Ik hoop dat je er wat aan hebt!

    Vond u dit antwoord nuttig?