1. Erik Mensen Member

    OSCommerce Admin inlog-probleem

    Topic geplaatst op: 29-03-2015 om 14:35

    Ineens kan ik niet meer inloggen in de Admin van OSCommerce. Bij het invoeren van het juiste wachtwoord blijft de pagina 'hangen' en kom ik niet verder.

    Bij het invoeren van een fout wachtwoord krijg ik een melding dat het wachtwoord fout is.
    Dit getuigd dus dat NA een juiste verificatie van de Admin-gegevens een fout in de website zit.

    Via DirectAdmin (installer) is OSCommerce geïnstalleerd. De laatste en meest actuele versie heeft dit probleem.
    Versio ondersteunt support op de aangeboden scripts niet, krijg ik als antwoord, dus kan ik de website niet meer bijwerken. Jarenlang heb ik aan de website gewerkt, weggooien is niet van toepassing.

    Kan iemand mij helpen? Heeft iemand ditzelfde ook toevallig onlangs meegemaakt?
    Mijn producten zijn voorjaars-gerelateerd, vandaar ik deze graag wil actualiseren via de Admin.

  2. Henk Van Dongen Member
    Reactie geplaatst op: 17-04-2015 om 21:02

    Dit probleem heb ik nu dus ook. Heel vervelend. Hopelijk heeft er iemand een oplossing?

    Vond u dit antwoord nuttig?

  3. Sander Keuzenkamp Member
    Reactie geplaatst op: 19-04-2015 om 13:07

    Open PHPmyAdmin en voeg de volgende 2 dingen toe:

    CREATE TABLE IF NOT EXISTS administrators (
    id int(11) NOT NULL auto_increment,
    user_name varchar(32) NOT NULL,
    user_password varchar(40) NOT NULL,
    PRIMARY KEY (id)
    ) ;

    INSERT INTO administrators (id, user_name, user_password) VALUES
    (1, 'adm', '2272bd2219e0bbc353e33f1e774c9d1e:11');

    Uw gebruikersnaam is nu: adm
    Wachtwoord: pass11

    Vergeet dit niet te veranderen ;)

    Vond u dit antwoord nuttig?

  4. Martin Philips Van Buren Member
    Reactie geplaatst op: 29-04-2015 om 12:45

    Vanwege dit inlogprobleem heb ik bovenstaande uitgevoerd, maar ik sta als admin met het juiste ww erin.

    Volgens mij komt dit door de upgrade van PHP naar 5.5
    Daarvoor heb ik al enkele bestanden moeten aanpassen om de winkel up en running te krijgen.
    Een testaankoop is dan ook goed gegaan, en ook andere aankopen komen goed binnen.
    Verder heb ik ook de .htaccess in de webshop moeten renamen, anders krijg ik totaal niets op het scherm.

    Enig idee verder?

    Groet, Martin.

    PS - het is osCommerce versie 2.2rc2.
    .

    Vond u dit antwoord nuttig?

  5. Saskia Hoofdman Member
    Reactie geplaatst op: 04-05-2015 om 15:41

    Hoi Martin,

    Ik kan mijn winkel ook helemaal niet meer benaderen door de update naar PHP5.5.

    Welke bestanden heb je aangepast om je winkel weer up en running te krijgen.

    Groetjes,
    Saskia

    Vond u dit antwoord nuttig?

  6. Martin Philips Van Buren Member
    Reactie geplaatst op: 04-05-2015 om 16:40

    Voor diegenen die hun shop weer online willen krijgen is hier een link naar een tijdelijke oplossing:
    http://www.inveostore.com/blog/oscommerce-with-register-globals-off/
    Haal eerst deze bestanden via FTP naar je eigen pc, verander ze dan met Notepad++ en upload ze weer.
    (PS - er staat ook dat het in de install map gedaan moet worden, maar deze zou niet aanwezig moeten zijn.)

    Het resultaat zal zijn dat de shop het weer doet.
    Nadeel is dat je er niet meer in komt als admin - dat werkt niet meer onder de nieuwe PHP.
    Onderhoud is dus niet mogelijk.

    Ik ben bezig met onderzoek in de admin routines om te proberen dat ook weer werkend te krijgen.

    Eigenlijk is een geheel nieuwe installatie van osCommerce 2.3.4. de enige goede oplossing.
    Betekent wel heel veel werk omdat alles opnieuw ingezet moet worden.
    Daar ben ik ook mee bezig om in ieder geval de klanten en orders over te krijgen.

    Groet, Martin.


    Vond u dit antwoord nuttig?

  7. Nicole Dieltjes Member
    Reactie geplaatst op: 10-05-2015 om 10:09

    Ik heb 2.3.4 geinstalleerd (schone install) maar heb hetzelfde probleem. Iemand enig idee?

    Vond u dit antwoord nuttig?

  8. Martin Philips Van Buren Member
    Reactie geplaatst op: 12-05-2015 om 13:27

    @Nicole,

    Hoe bedoel je?
    Hoe heb je de installatie gedaan?
    En op welke server zit je?

    Groet, Martin.

    Vond u dit antwoord nuttig?

  9. Björn Cornelissen Member
    Reactie geplaatst op: 18-05-2015 om 15:35

    Zelfde probleem met mijn oscommerce 2.3.3.

    Site zelf werkt prima en kan er besteld worden alleen het admin paneel kan niet benadert worden een compleet witte pagina.
    Heb versio al gevraagd of ik via een handler 5.3 of 5.2 kan aanroepen maar helaas is dat niet mogelijk.

    Vond u dit antwoord nuttig?

  10. Björn Cornelissen Member
    Reactie geplaatst op: 19-05-2015 om 13:06

    Dit is wat ik gevonden heb als tijdelijke oplossing als je last heb van de nieuwe php en daarvan melding krijgt dat je niet kan inloggen.

    Voor mij werkte het.



    I`ve had this issue too, its due to a bug in the actionRecorderAdmin class I`ve not looked into that but this workaround solves the issue:

    in login.php find:
    if ($actionRecorder->canPerform()) {
    replace with:

    if (1 == 1) {

    Note this does also disable recording the logins, someone needs to find the bug to avoid that! :huh:


    PS deleting all the entries from action_recorder table doesn't help the issue.

    Vond u dit antwoord nuttig?

  11. Martin Philips Van Buren Member
    Reactie geplaatst op: 22-05-2015 om 15:27

    Het aanpassen van deze login.php geldt alleen voor osCommerce 2.3.4.

    Als je osCommerce 2.3.4 geïnstalleerd via Installatron, dan zou ik die installatie ongedaan maken en opnieuw installeren via FTP upload en install.
    Het gaat niet altijd goed als je Installatron gebruikt.

    Op deze manier heb ik mijn admin login opgelost.

    Groet, Martin.

    Vond u dit antwoord nuttig?

  12. Nicole Dieltjes Member
    Reactie geplaatst op: 30-05-2015 om 21:49

    Dag!

    Ik heb 2.3.4 geïnstalleerd.
    Dus ik zou graag de deinstallatie uitvoeren en dan opnieuw installeren (zonder auto installer). Ik vraag mij dan alleen af of ik de back-up en bestanden dan terug kan zetten of dat ik daarmee het probleem weer upload. ?!

    Vond u dit antwoord nuttig?

  13. Martin Philips Van Buren Member
    Reactie geplaatst op: 31-05-2015 om 18:03

    @Nicole,

    De enige manier om dit soort fouten eruit te halen is het opnieuw installeren (maar dan niet via Installatron !!).
    Wel kan je de database bewaren en later uploaden.

    *******************************

    Voor diegenen die onderhoud aan hun "oude" winkel willen plegen, heb ik een document op mijn website geplaatst waarin aanpassingen aan de producten plaatsvinden die u daarna kan uploaden.
    http://www.acebe.nl

    Groet, Martin.

    Vond u dit antwoord nuttig?

  14. Nicole Dieltjes Member
    Reactie geplaatst op: 01-06-2015 om 19:24

    @Martin Philips Van Buren ik heb zojuist alles verwijderd, nieuwe db aangemaakt. Oscommerce 2.3.4. gedownload en handmatig geinstalleerd maar ik kan er nog niet in! Admin inlog gebeurd er niets!

    Vond u dit antwoord nuttig?

  15. Martin Philips Van Buren Member
    Reactie geplaatst op: 02-06-2015 om 01:04

    @nicole,

    Wil je mij een berichtje sturen via http://www.acebe.nl met user en ww?
    Ik kan dan bij jou kijken wat er aan de hand is.

    Ook anderen mogen via dit adres een berichtje sturen als iets niet goed gaat.

    Groet, Martin.

    Vond u dit antwoord nuttig?

  16. Nicole Dieltjes Member
    Reactie geplaatst op: 09-06-2015 om 08:14

    @Martin Philips Van Buren, zojuist gedaan. Probleem leek verholpen na handmatige install oscommerce maar duikt nu na een week weer op.

    Txs!

    Vond u dit antwoord nuttig?