1. hipperdehopper Member

    Php 5.3 naar 5.4

    Topic geplaatst op: 21-03-2015 om 22:05

    Is er geen optie om vanaf je panel je hele systeem om te zetten naar php 5.4 ? want je kan wel de regel :

    <FilesMatch ".php$">
    AddHandler x-httpd-php54 .php
    </FilesMatch>

    gebruiken om dit inte stellen maar dit accepteerd het script dat ik voor een klant moet instaleren niet.

    Je krijgt dan direct een 500 internal server error

    en haal ik het uit de htacces wil het wel starten alleen geeft de fout systeem heeft verouderde versie blabla

    mis iets voor versio dit als optie te maken ?

  2. Fabien Daniel Versio medewerker
    Reactie geplaatst op: 22-03-2015 om 22:31

    Hallo, er wordt weldra een PHP update uitgevoerd op de shared webhosting en reseller pakketten.

    Na het toevoegen van de PHP 5.4 code kan je nagaan of alle mappen op 755 staan en bestanden op 644. Alsook nagaan of de DirectAdmin username staat vermeld in de UID/GID kolom in de File manager van DirectAdmin.

    Een internal server error wijst erop dat de rechten niet correct ingesteld staan op uw mappen en bestanden.

    Vond u dit antwoord nuttig?

  3. Harry Vos Member
    Reactie geplaatst op: 24-03-2015 om 09:09

    Bij de installatie van php 5.5 blijven dan alle websites normaal draaien?
    Ik heb op mijn resellerpakket n.l. nog een website van een klant staan die gebouwd is in Joomla 1.5

    Vond u dit antwoord nuttig?

  4. Fabien Daniel Versio medewerker
    Reactie geplaatst op: 25-03-2015 om 21:08

    @Harry Vos De recente versies van scripts en CMS systemen zullen correct blijven draaien.

    Joomla 1.5 is reeds geruime tijd niet meer ondersteund door de makers. Deze zullen mogelijk niet meer correct werken nadien. Joomla 1.5 werkt zeker correct tot en met PHP 5.3. Daarboven kan ik niet met zekerheid zeggen.

    Bovendien is het best te upgraden naar de laatste Joomla versie om te voorkomen dat deze oudere websites en plugins gehackt worden.

    Vond u dit antwoord nuttig?

  5. David Vandenbroeck Member
    Reactie geplaatst op: 07-04-2015 om 21:10

    Ik heb hetzelfde probleem, telkens als ik bovenstaande code in mijn .htaccess zet, dan krijg ik een 500 internal server error. Al mijn mappen staan tevens op 755 en bestanden op 644. Ook de directadmin username staat correct bij UID/GID. Ik heb al redelijk veel geprobeerd en ben toch een beetje verveelt omdat de verouderde PHP toch tal wat problemen meegeeft, zoals het niet versturen van e-mails bij bestellingen...

    Wat zou ik hiervoor nog kunnen doen? Want het e-mail problemen zou toch snel opgelost moeten worden..

    Van welke PHP script kan ik de extensie veranderen naar .php54?
    Alleen dit heb ik nog niet geprobeerd..

    Weet iemand raad?

    Vond u dit antwoord nuttig?

  6. Fabien Daniel Versio medewerker
    Reactie geplaatst op: 07-04-2015 om 21:20

    @David Vandenbroeck U kunt hiervoor een support ticket aanmaken in het klantenpaneel en het domein vermelden. We zullen dit dan voor u nakijken.

    Vond u dit antwoord nuttig?

  7. John Vd Burg Member
    Reactie geplaatst op: 15-05-2015 om 11:01

    Voor joomla plaats deze code in je .htaccess

    php_flag display_startup_errors off
    php_flag display_errors off
    php_flag html_errors off
    php_value docref_root 0
    php_value docref_ext 0

    Vond u dit antwoord nuttig?