1. Angela Van Der Ploeg Member

    Updaten WP werkt niet

    Topic geplaatst op: 26-11-2014 om 15:47

    Updaten naar de nieuwste versie van Wordpress werkt niet. Zowel in de DirectAdmin niet als via het Dashboard. Ik krijg volgende melding in het Dashboard:

    Uitpakken update…

    Warning: copy(/home/angelln34/domains/praktijk-havayah.nl/public_html/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: Permission denied in /home/angelln34/domains/praktijk-havayah.nl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 217

    De update kon niet worden geïnstalleerd omdat we sommige bestanden niet konden kopiëren. Dit komt meestal door inconsistente bestandsrechten.: wp-admin/includes/update-core.php

    Installatie is mislukt

    De melding in de DirectAdmin is:

    Error
    PHP for the selected domain has failed.

    Installatron is unable to install to a domain where PHP is not working.

    Your hosting provider can help you resolve this error.

    Error code: 1; HTTP code: 500


    Het zijn 2 websites die ik bij jullie heb die niet kunnen updaten. Een andere die bij jullie zit, gaat wel.
    Beiden hebben alle files op hetzelfde staan, dat heb ik nagekeken.

    Dus ligt het aan de server of zo?
    Server is: 034

    ht gaat om de volgende website: http://www.praktijk-havayah.nl en http://informatief.praktijk-havayah.nl

    Graag met spoed help. (en nee, ik wil het niet handmatig via ftp doen, want het moet gewoon normaal werken)

  2. Gerald Van Wattum Versio medewerker
    Reactie geplaatst op: 26-11-2014 om 22:39

    U kunt proberen uw website in PHP 5.4 modus te draaien wat voor rechten problemen oplost.
    U dient daarvoor het volgende aan het .htaccess bestand toe te voegen die u vindt in de public_html map van de Filemanager:

    <FilesMatch ".php$">
    AddHandler x-httpd-php54 .php
    </FilesMatch>

    De rechten van de mappen met php 5.4 in de public_html op 755 te staan, en alle bestanden op 644. LET OP dit geld ook op alle onderliggende mappen in de public_html

    Mocht het toch niet lukken, maak dan een ticket aan in uw klantenpaneel onder uw helpdesktickets. Stuur uw directadmin gegevens mee en dan zullen wij dit verder voor u nakijken.

    Vond u dit antwoord nuttig?

  3. Angela Van Der Ploeg Member
    Reactie geplaatst op: 27-11-2014 om 11:53

    Ik ga dit straks even uitproberen.
    Welk gek dat alle andere wel gewoon updaten zonder dat er iets moet worden veranderd.

    Ik laat nog even horen of het gelukt is.

    Vond u dit antwoord nuttig?

  4. Angela Van Der Ploeg Member
    Reactie geplaatst op: 27-11-2014 om 12:48

    .htaccess file aangepast en ik kreeg na updaten een of andere melding dat het niet goed gegaan was. Ik had her hier opgeschreven, maar opeens is mijn bericht weg.
    Dus ik weet het niet meer uit mijn hoofd.

    Daarna geeft de DirectAdmin nog steeds aan dat de oude versie 4.0 is geinstalleerd, maar het dashboard geeft aan de nieuwe versie te hebben.

    Het subdomein op dezelfde manier een update gegeven (dus ook .htaccess aangepast) en die ging wel in 1 keer goed.

    DirectADmin opnieuw herstart en nu staat er wel dat de nieuwe versie is geinstalleerd.
    Toch wel gek dat het zo gaat. Maar goed, het is voor nu opgelost!!

    Dank voor de tipc van de .htaccess.

    Vond u dit antwoord nuttig?