1. Lissa Agema Member

    Wordpress update vertaling

    Topic geplaatst op: 26-09-2014 om 10:42

    Ik heb de laatste 2 weken op diverse domeinen Wordpress geïnstalleerd.
    Maar bij al deze domeinen lukt de update 'Vertaling' niet.

    Hieronder een voorbeeld van een van deze domeinen. Iemand een idee hoe ik dit op kan lossen?

    Warning: copy(/home/ebytes/domains/e-bytes.nl/public_html/wp-content/languages/nl_NL.po) [function.copy]: failed to open stream: Permission denied in /home/ebytes/domains/e-bytes.nl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 217

    Warning: copy(/home/ebytes/domains/e-bytes.nl/public_html/wp-content/languages/nl_NL.po) [function.copy]: failed to open stream: Permission denied in /home/ebytes/domains/e-bytes.nl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 217

  2. Gerald Van Wattum Versio medewerker
    Reactie geplaatst op: 26-09-2014 om 10:53

    U kunt proberen uw website in PHP 5.4 modus te draaien wat voor rechten problemen oplost.
    U dient daarvoor het volgende aan het .htaccess bestand toe te voegen die u vindt in de public_html map van de Filemanager:

    <FilesMatch ".php$">
    AddHandler x-httpd-php54 .php
    </FilesMatch>

    De rechten van de mappen met php 5.4 in de public_html op 755 te staan, en alle bestanden op 644. LET OP dit geld ook op alle onderliggende mappen in de public_html

    Vond u dit antwoord nuttig?

  3. Lissa Agema Member
    Reactie geplaatst op: 26-09-2014 om 11:20

    Dank je Gerald!

    Dit heb ik zojuist geprobeerd en het werkt!

    Vond u dit antwoord nuttig?

  4. Lissa Agema Member
    Reactie geplaatst op: 26-09-2014 om 20:27

    De updates zijn gelukt vanmorgen, daar was ik heel blij mee.
    Maar door deze actie werken nu andere functies niet meer. Zo kan ik nu geen nieuwe plugins toevoegen omdat het scherm dan niet geladen wordt en een van de plugins wil nu niet laden. (Thrive Content Builder).

    Vond u dit antwoord nuttig?

  5. Gerrit Hendrik De Ruiter Member
    Reactie geplaatst op: 29-09-2014 om 19:57

    Ik heb dezelfde foutmelding.
    Het komt mij vreemd over, dat bij een vers opgeleverde hosting en nieuwe site en een nieuwe installatie van wordpress, dat het niet gewoon werkt. Heb dit nog niet bij andere hostingproviders meegemaakt.

    Je mag toch uitgaan dat zeker wordpress gewoon netjes is te installeren zonder problemen, of handmatige aanpassingen.

    ben benieuwd of Versio met een betere oplossing komt.

    Vond u dit antwoord nuttig?

  6. Lissa Agema Member
    Reactie geplaatst op: 29-09-2014 om 20:05

    Inderdaad Gerrit, dat ben ik met je eens.
    Ik heb ook nog op een andere domein die elders staat Wordpress draaien en daar is helemaal geen probleem mee.

    Maar mijn oplossing was uiteindelijk van de week: script toevoegen en poorten zonodig aanpassen. Daarna update uitvoeren. Dat ging goed.

    Daarna werkten er meerdere onderdelen niet meer en toen heb ik het script weer verwijderd en de poorten terug gezet.

    Gevolg: update was geslaagd en daarna werkte de rest weer. Maar nu hoop ik niet dat ik steeds dit verhaal moet gaan doen wanneer er nieuwe updates zijn.

    Vond u dit antwoord nuttig?

  7. Steffen Schouwenaar Member
    Reactie geplaatst op: 30-12-2014 om 21:20

    Ik weet niet of je de oplossing al hebt, ik had exact hetzelfde probleem en heb het opgelost door de bestandsrechten van :
    wp-content>languages>nl_NL.po
    op 777 te zetten.

    Vond u dit antwoord nuttig?

  8. golfer1 Member
    Reactie geplaatst op: 08-01-2015 om 12:06

    Wordpress geoptimaliseerde sites werken niet met php 5.4.
    Ik heb ook al eerder gemeld dat deze problemen zijn ontstaan nadat er een totaal andere wp-config.php wordt geinstalleerd.
    Ik heb deze file die nu wordt geinstalleerd met een file van drie jaar geleden.
    Het valt mij op dat het stuk van chmode bestanden mappen op 777 en files op 666 staan.

    Vond u dit antwoord nuttig?

  9. Asimov Member
    Reactie geplaatst op: 18-05-2015 om 16:27

    Het is jammer, dat dit probleem telkens weer opduikt. Bij de update naar Wordpress 4.2.2. geven de vertalingen dezelfde foutmeldingen als vorig jaar. Ik heb de permissions zoals aangegeven tijdelijk op 777 gezet, maar helaas. Nog iemand andere suggesties?

    Hieronder de meldingen:

    Warning: copy(/home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-content/languages/admin-nl_NL.po) [function.copy]: failed to open stream: Permission denied in /home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 231

    Warning: copy(/home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-content/languages/admin-nl_NL.po) [function.copy]: failed to open stream: Permission denied in /home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 231
    Kan bestand niet kopiëren /home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-content/languages/admin-nl_NL.po

    Vertaling bijwerken is mislukt.

    Vertalingen bijwerken voor Akismet (nl_NL)…


    Warning: copy(/home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-content/languages/plugins/akismet-nl_NL.mo) [function.copy]: failed to open stream: Permission denied in /home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 231

    Warning: copy(/home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-content/languages/plugins/akismet-nl_NL.mo) [function.copy]: failed to open stream: Permission denied in /home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 231
    Kan bestand niet kopiëren /home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-content/languages/plugins/akismet-nl_NL.mo

    Vertaling bijwerken is mislukt.

    Vertalingen bijwerken voor Twenty Fourteen (nl_NL)…


    Warning: copy(/home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-content/languages/themes/twentyfourteen-nl_NL.mo) [function.copy]: failed to open stream: Permission denied in /home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 231

    Warning: copy(/home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-content/languages/themes/twentyfourteen-nl_NL.mo) [function.copy]: failed to open stream: Permission denied in /home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 231

    Kan bestand niet kopiëren /home/phviljme/domains/knooppuntmontfoort.nl/public_html/wp-content/languages/themes/twentyfourteen-nl_NL.mo

    Vertaling bijwerken is mislukt.

    Vond u dit antwoord nuttig?

  10. Justin Kil Versio medewerker
    Reactie geplaatst op: 18-05-2015 om 16:37

    Beste Asimov,

    Ik heb het één en ander voor u aangepast. Kunt u de update nog eens uitvoeren?

    Ik hoor graag wat het resultaat is.

    Justin - Helpdesk medewerker

    Vond u dit antwoord nuttig?

  11. Asimov Member
    Reactie geplaatst op: 18-05-2015 om 17:03

    Justin,

    Ik heb de update opnieuw uitgevoerd en het werkt. Bedankt voor de zeer snelle service!!

    Rob

    Vond u dit antwoord nuttig?

  12. Justin Kil Versio medewerker
    Reactie geplaatst op: 18-05-2015 om 17:09

    Hallo Rob,

    goed om te horen, geen dank.

    Fijne avond,

    Justin - Helpdesk medewerker

    Vond u dit antwoord nuttig?

  13. Hans Posthumus Member
    Reactie geplaatst op: 02-06-2015 om 20:00

    Beste Justin,

    Ik loop met één van de domeinen eigenlijk tegen hetzelfde probleem aan. Wat dien ik aan te passen zodat het wel werkt?

    Gaat om de domein PerfectChalet.

    Mvg
    Rutger

    Vond u dit antwoord nuttig?

  14. Fabien Daniel Versio medewerker
    Reactie geplaatst op: 02-06-2015 om 20:12

    @Hans Posthumus Ik heb de rechten gereset op uw mappen en bestanden alsook de rechten ingesteld op 755. Kunt u nogmaals nagaan of het werkt voor u?

    Vond u dit antwoord nuttig?

  15. Hans Posthumus Member
    Reactie geplaatst op: 03-06-2015 om 15:37

    Hoi Fabian,

    Als ik nu naar mijn domein ga krijg ik error 500 Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request
    www.perfectchalet.com

    Hier is dus iets mis gegaan als je het mij vraagt. Kan ook niet meer inloggen op Wordpress voor dit domein.

    Mvg

    Rutger

    Vond u dit antwoord nuttig?

  16. Fabien Daniel Versio medewerker
    Reactie geplaatst op: 03-06-2015 om 15:46

    @Hans Posthumus Er stond weer PHP 5.4 code in uw .htaccess bestand, deze is nu weggehaald. Dit veroorzaakte de foutmelding.

    Vond u dit antwoord nuttig?

  17. Hans Posthumus Member
    Reactie geplaatst op: 03-06-2015 om 15:47

    Hoi Fabian,

    Bedankt voor het snelle handelen. het werkt nu inderdaad goed en ik kan updaten.

    Mvg

    Rutger

    Vond u dit antwoord nuttig?

  18. Hans Posthumus Member
    Reactie geplaatst op: 03-06-2015 om 15:53

    Hoi Fabian,

    Krijg nog wel onderstaande foutmelding als ik update naar 4.2 wil doen. Vertalingen zijn nu wel gelukt maar versie update doet het nog niet:
    Downloaden update van https://downloads.wordpress.org/release/nl_NL/wordpress-4.2.2.zip…

    Uitpakken update…


    Warning: copy(/home/teambez119/domains/perfectchalet.com/public_html/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: Permission denied in /home/teambez119/domains/perfectchalet.com/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 217
    De update kon niet worden geïnstalleerd omdat we sommige bestanden niet konden kopiëren. Dit komt meestal door inconsistente bestandsrechten.: wp-admin/includes/update-core.php

    Installatie is mislukt

    Mvg
    Rutger

    Vond u dit antwoord nuttig?