1. Ron Dupon Member

    DirectoryIndex foutje?

    Topic geplaatst op: 22-11-2011 om 21:37

    Ik heb zojuist een subdomeinnaam aangemaakt en kwam er dus achter dat de DirectoryIndex in httpd.conf niet goed staat.
    Als ik naar http://sub.domein.com/ ga krijg ik de 404 melding en als ik naar http://sub.domein.com/index.html ga krijg ik netjes de placeholder pagina.
    Ik weet niet of jullie dit expres hebben gedaan of dat dit een klein foutje is, maar zou wel graag hebben dat ie eerst .html dan .php enzo pakte.
    Ik zit btw op server 059.. (Waar geloof ik vandaag ook wat probleempjes mee waren, die nu netjes opgelost zijn.)

  2. wouter1987 Member
    Reactie geplaatst op: 24-11-2011 om 01:55

    Ik heb in Direct admin gekeken of je dit kunt instellen. Ik kan het niet vinden, maar dat zegt natuurlijk niks.

    Je kan mailen naar support@versio.nl of je PHP script in een andere map zetten.

    Ik hoop dat het gaat lukken. Omdat versio ruim een dag later ook niet heeft gereageerd ga ik er vanuit dat het geen storing is. Maar ik kan me natuurlijk vergissen.

    Vond u dit antwoord nuttig?

  3. Ron Dupon Member
    Reactie geplaatst op: 24-11-2011 om 20:59

    Het heeft niets te maken met of ik php files in die map heb staan, ik heb zelfs nog geen php files in die map staan alleen de standaard placeholder (klein standaard html paginaatje) die door DirectAdmin er zelf in is gezet.
    Het gaat erom dat als je naar je (sub)domein gaat hoort hij eerst de index.html of de index.php te laten zien en als die niet bestaan pas een 404 bericht te laten zien.
    Dit doe simple je door het httpd.conf bestand aan te passen bij DirectoryIndex, dit hoort bij de standaard configuratie van Apache.
    Maar ik zal ze er eens een mailtje over sturen, wel raar dat er niet regeageerd wordt er staat namelijk gewoon "Ook de medewerkers van Versio zijn in het klanten forum actief om u te ondersteunen bij vragen." boven aan de begin pagina van het forum.

    Vond u dit antwoord nuttig?

  4. wouter1987 Member
    Reactie geplaatst op: 25-11-2011 om 18:12

    OK, Heb je al antwoord? Je bent zo te horen kundiger dan ik :)

    Vond u dit antwoord nuttig?

  5. Bernard Kok Member
    Reactie geplaatst op: 24-01-2015 om 17:54

    Ben nieuw hier maar had net het zelfde probleem... ;-)

    www.sub.domein.nl laad wel maar
    sub.domein.nl geeft erro pagina.... volgenes mij nu ophgelost door een A regel toe te voegen in dns beheer met sub.domein.nl en daan naar je IP adres van je nameserver van je eigen server bij versio...
    Schijnt hier de beoel op te lossen ;-) hoop dat het echt werkt...

    Vond u dit antwoord nuttig?