1. z3f Member

    IPv6

    Topic geplaatst op: 24-04-2014 om 21:18

    Wanneer zal IPv6 enabled worden op de cloudbox omgevingen?

  2. Alex Boon Versio medewerker
    Reactie geplaatst op: 25-04-2014 om 12:42

    Beste,

    IPv6 word momenteel getest op onze cloudbox omgevingen. Hoelang dit precies nog op zich laat wachten is helaas nog niet bekend.

    Vond u dit antwoord nuttig?

  3. Tom Denkers Member
    Reactie geplaatst op: 25-04-2014 om 14:59

    Het IPv6 adres is toegevoegd aan uw VM en is live. Alles moet nu goed voor u werken!

    Vond u dit antwoord nuttig?

  4. Bart Barbé Member
    Reactie geplaatst op: 26-04-2014 om 02:05

    Super, IPv6 werkt nu indd op de cloudbox omgeving.  Alleen kan ik het adres nog niet reserveren via de ACX webpagina, waardoor na reboot er een nieuw ipv6 adres op de machine komt.

    Foutboodschap ACX : This can't be used, because you have reached your IP address limit

    Kan dit nog statisch gezet worden?

    Vond u dit antwoord nuttig?

  5. zeromechanic Member
    Reactie geplaatst op: 27-04-2014 om 00:23

    Hier zelfde probleem.

    Ik kan maar 2 ipv6 kiezen. Zou onbeperkt zijn.

    Em als ik ze al kies, krijg ik ook de melding  van die limit.

    Erg frusterend aangezien ik mijn server weken geleden al ipv6 ready EN werkend had.

    Zelfs enkele ipv6 al in gebruik had.

    Deze waren toen ineens verdwenen.

    Vond u dit antwoord nuttig?

  6. Tom Denkers Member
    Reactie geplaatst op: 27-04-2014 om 17:04

    Voor IPv6 dien je wel een nieuwe netwerkkaart met een willekeurige naam toe te voegen in de 'IPV6 Zone' .  Vervolgens kan je aan deze netwerk kaart onbeperkt ipv6 adressen hangen zonder problemen:)

    Vond u dit antwoord nuttig?

  7. zeromechanic Member
    Reactie geplaatst op: 27-04-2014 om 17:46

    Dat had ik al gedaan.
    Verwijderd en een nieuwe aan gemaakt.
    reboot van de machine lukt niet volgens de rode balk.


    In de pull down vershijnen geen ipv6

    Alleen onder de eth0 staan er 2, die ik niet kan gebruiken.

    rebuild network werkt ook niet, force option not enabled zegt ie dan bij de error
     

    Vond u dit antwoord nuttig?

  8. zeromechanic Member
    Reactie geplaatst op: 27-04-2014 om 17:46

    oja node8

    Vond u dit antwoord nuttig?

  9. Tom Denkers Member
    Reactie geplaatst op: 28-04-2014 om 10:21

    Aangezien de lijst met IPv6 adressen redelijk groot is kan het een paar seconden laden duren. Vervolgens heb ik bij je IPv6 netwerk adapter het IP toegevoegd en draait nu de network rebuild. De server zal zo online komen, met IPv6 ingeschakeld!

    Vond u dit antwoord nuttig?

  10. Bart Barbé Member
    Reactie geplaatst op: 28-04-2014 om 10:34

    Yup, zo lijkt het te werken nu.  Indd even wachten en dan komen de adressen te voorschijn.

    Na de netwerk rebuild indd de 2 adapters zichtbaar, waarbij de 2de een statisch ip heeft.

    Misschien wel goed om klanten te laten weten dat ipv6 enabled is op de gewone netwerk adapter ook (met autoconfig adressen) want als men ip6tables niet geactiveerd heeft, maar het OS wel ipv6 ready is, ligt die server open op het internet.

    Vond u dit antwoord nuttig?

  11. zeromechanic Member
    Reactie geplaatst op: 28-04-2014 om 21:33

    Ok je moet idd ff wachten voor dat je de ipv6 te zien krijgt.
    als dat iets sneller zou kunnen......

    Alleen als ik de adressen toevoeg, zijn ze niet te bereiken.
    het adres wat Tom heeft toegevoegd wel.

    Dus ik denk dat is een rebuild.
    ken geen kwaad om uit te proberen. tis Tom ook gelukt ;););)

    maar als ik keurig op rebuild klik, :

    Fatal: Can't connect to online server [159.253.XXX.XXX], force option not enabled! Executing Rollback...

    Als ik het goed bekijk, doet deze rebuild niks anders dan het interfaces bestand (ik gebruik debian) herschrijven.

    Vrûger, doe ik op node2 de IPV6 gebruikte, had ik hetzelfde probleem.
    Ik heb toen het volgende in mijn interfaces gezet :

    #IPV6 static configuration
    iface eth0 inet6 static
    pre-up modprobe ipv6
    address 2a02:27f8:1050::10
    netmask 64
    gateway 2a02:27f8:1050::1
    # END IPV6 configuratio
    up /sbin/ifconfig eth0 inet6 add 2a02:27f8:1050::13/64
    up /sbin/ifconfig eth0 inet6 add 2a02:27f8:1050::14/64
    up /sbin/ifconfig eth0 inet6 add 2a02:27f8:1050::15/64
    up /sbin/ifconfig eth0 inet6 add 2a02:27f8:1050::18/64
    up /sbin/ifconfig eth0 inet6 add 2a02:27f8:1050::21/64

    En dat werkte als een speer.
    IPv6 onderaan toevoegen, netwerking restart en voila nieuwe adres was actief

    Alleen ziet mijn interfaces er nu anders uit.

    auto eth1
    iface eth1 inet static
        address 127.0.0.2
        netmask 255.255.255.255
    iface eth1 inet6 static
        address 2001:67c:4f8:1000::6
        netmask 64
        gateway  2001:67c:4f8:1000::1
        post-up ip route add default via 2001:67c:4f8:1000::1 table eth1_if
        post-up ip rule add from 2001:67c:4f8:1000::6 table eth1_if
        post-down ip rule del from 2001:67c:4f8:1000::6 table eth1_if

    Dit werkt nu wel, en vrûger niet..
    Aangezien de rebuild niet werkt, kan ik ook niet zien of er iets veranderd aan de interfaces

     

    Vond u dit antwoord nuttig?

  12. zeromechanic Member
    Reactie geplaatst op: 28-04-2014 om 23:01

    Okee, ik heb hem door.

    Ik heb nu de optie force reboot -> gracefully gebruikt.

    Nu doet ie het wel.
    IPv6 werkend op mn server.
     

    zag alleen een melding voorbij komen : failed to bring up eth1
    maar was net te snel om te zien wat het was.

    heb bootlog maar eens ingesteld

    Vond u dit antwoord nuttig?

  13. zeromechanic Member
    Reactie geplaatst op: 28-04-2014 om 23:10

    Maar ik kom nu op het volgende.

    Gmail accepteert ipv6 adressen ALLEEN met een reverse DNS.
    Komt er nog een optie in het klantenpaneel om dit zelf in te voegen? Een PTR record?

    Vond u dit antwoord nuttig?