1. zeromechanic Member

    Gebruik van IPv6

    Topic geplaatst op: 09-11-2013 om 19:34

    Beste allemaal,

    Na mijn eerder post over de ipv6 te gebruiken, en met de chat van versio, die mij melde dat het niet werkte.
    Tevens las ik op het forum dar er mnsen zijn die dit wel voor elkaar gekregen hadden.

    Ik heb nu dus inmiddels IPv6 werkend en actief op mijn server.
    Zover ik weet werkt dit alleen nog maar op node2

    Linux zou standaard IPv6 moeten ondersteunen.
    wat was het in mijn geval.
    Ik had Debian 6.0 x64 geinstalleerd.
    deze handmatig geupgraded naar debian 7.2 Wheezy

    Na wat speurwerk kwam ik er achter dat het lag een de kernel versie die bij debian 6.0 kwam.
    normaal hoort bij debian 7 een andere kernel, een nieuwere.

    debian 6 = kernel 2.6.32-amd64

    debian 7 zou moeten zijn : 3.2.0-4-amd64

    Op een eenof andere manier was dat niet goed gegaan

    Ik kwam daar achter omdat modprobe ipv6 een foutmelding gaf !!!!!
    als dit niet werkte moest je naar een andere kernel overstappen.

    Bij de upgrade naar wheezy is dit niet in de bootloader gezet.
    waarschijnlijk omdat het een virtueel systeem is.

    heb dit handmatig aangepast in /boot/grub/menu.lst
    door simpelweg wat er al stond aan te passen naar de kernel die al bij de upgrade in de /boot directory stond.

    Nu starte de VM op in kernel 3.2 en werkte modprobe ipv6

    Nu het configureren van de IPv6 onder Debian 7.2:

    Natuurlijk moet je in de VM console wel ipv6 adressen hebben ingeschakeld !!!!

    na enig klooien kwam ik er achter dat je een FULL IPv6 adres moest gebruiken.
    voor het 1e adres dus een full IPv6 gebruiken.Dit ook voor de gateway.

    voor eventuele extra adressen is dit niet nodig.
    vraag mij niet waarom, maar bij werkte het zo

    uitrekenen bij https://www.ultratools.com/tools/ipv6Expand


     

    mijn config:
    #IPV6 static configuration
    iface eth0 inet6 static
    pre-up modprobe ipv6
    address 2a02:27f8:1050:0:0:0:0:10
    netmask 64
    gateway 2a02:27f8:1050:0:0:0:0:1
    # END IPV6 configuratio
    up /sbin/ifconfig eth0 inet6 add 2a02:27f8:1050::13/64
       up /sbin/ifconfig eth0 inet6 add 2a02:27f8:1050::14/64
    up /sbin/ifconfig eth0 inet6 add 2a02:27f8:1050::15/64

    Even network restart, en voila ik had ipv6 connectie.

     

  2. zeromechanic Member
    Reactie geplaatst op: 09-11-2013 om 19:45

    zeromechanic.nl.eu.org is een ipv6 website, alleen een AAAA record naar mijn 1e IP adres.

    validatie van ipv6 websites :

    http://ipv6-test.com/validate.php

    Mocht het in je browser niet direct werken dien je een tunnel aan te maken onder windows :

    http://www.tunnelbroker.net/

    Tip over tunnel broker : als je de informatie gebruikt, geef je EIGEN ip adres op als startput.
    indien je op een wifi of router zit, dien je je EIGEN ip adres later aan te passen naar het interne IP adres van je pc (bv 192.168.1.12)

    netsh interface ipv6 add v6v4tunnel interface=IP6Tunnel INTERNIPVANJEPC 216.66.84.46

    volg de instructies op via die site.

    Indien je rechtstreeks dan naar het ip wilt gaan, moet je de ipv6 adres tusset haakjes zetten.

    http://[2a02:27f8:1050::10]

     

    Vond u dit antwoord nuttig?

  3. eenklant Member
    Reactie geplaatst op: 09-11-2013 om 20:28

    Dus als ik het goed begrijp dan werkt het op node01 niet?

    Was ook van plan om me er in te verdiepen, zal ook maar eens gaan beginnen chatten met versio :)))))

    Aanmaken dat is geen probleem maar werkende krijgen is iets anders op CentOS 6.0 64-Bit + DirectAdmin.

    https://www.ultratools.com/tools/ipv6Expand handig linkje nu weet ik waarom directadmin van 2a02:27f8:1051::9 naar 2a02:27f8:1051:0:0:0:0:9 maakt.

     

     

     

     

    Vond u dit antwoord nuttig?

  4. zeromechanic Member
    Reactie geplaatst op: 09-11-2013 om 20:44

    Je kunt het wel checken of je ipv6 hebt op je node.

    inloggen op cloud, vm aan klikken, networking, network interfaces

    als je daar eth1 kun selecteren heb je beschikking over ipv6 Adressen.

    Zou versio wel sieren om zowiezo de ipv6 interface op alle nodes te activeren.
    met wat creativiteit kun je dus wel ipv6 gebruiken op je server.

    versio geeft aan nl dat het bij het aanmaken ergens iets niet goed gaat en dat de engineers er druk mee bezig zijn.
    in je interfaces wordt nl een eth1 aangemaakt, welke bij het booten een foutmelding geeft van RNetlink oid

    ik heb de ipv6 op deze manier gekoppeld aan de eth0

    Alleen heb je het probleem dat veel ISP's (bv tele2) je geen native ipv6 geven.

    dus via een tunnel werkt het als een speer

    Vond u dit antwoord nuttig?

  5. zeromechanic Member
    Reactie geplaatst op: 09-11-2013 om 20:46

    bij networking add interface niet eth1, maar als je daar een ipv6 pool kunt selecteren.

    public-NL ipv6

    dan kun je ipv6 adressen selecteren

    Vond u dit antwoord nuttig?

  6. eenklant Member
    Reactie geplaatst op: 10-11-2013 om 05:54

    Zoals ik al dacht gaat dus niet, duurd nu toch wat al veel te lang naar mijn gedacht.

    "Zou versio wel sieren om zowiezo de ipv6 interface op alle nodes te activeren."

    Dat zou zeker zo zijn.

    "met wat creativiteit kun je dus wel ipv6 gebruiken op je server."

    Dat is eigenlijk niet de bedoeling, het zou zonder creatieveteit moeten werken.

    "versio geeft aan nl dat het bij het aanmaken ergens iets niet goed gaat en dat de engineers er druk mee bezig zijn."

    Dat zijn ze nu meer dan een jaar mee bezig, zoek hier op forum eens naar ipv6 genoeg topics over.

    "bij networking add interface niet eth1, maar als je daar een ipv6 pool kunt selecteren.

    public-NL ipv6

    dan kun je ipv6 adressen selecteren"

    Kan bij Allocate New IP Address from Global Pool enkel eth0, ipv6_be, ipv6_nl, publik_be selecteren

    bij publik_be geen adressen, eth0, ipv6_be, ipv6_nl kan ik wel adressen aanmaken, bij Add New Network Interface kan ik niks aanmaken.

    Een screenshot van mijn omgeving network interfaces.

     

    Vond u dit antwoord nuttig?

  7. zeromechanic Member
    Reactie geplaatst op: 10-11-2013 om 12:18

      wat ik zo zie kun je ipv6 adressen gebruiken.

    De interfaces heb je ja al geselecteerd.

    Je hebt de keuze uit be en nl adressen.

    Selecteer een adres en klik op add adress assignemnet.

    Ook dien je op rebuild network te klikken.

    Als je dan op de mainpage van je console bent zie je rechts de ipv6 adressen staan.

    Ipv4 h3b je er idd maar 1 van.

     

    In mijn systeem kan ik zelfs met ipv6 verbinden met ftp.

    Men zegt! Dat je eigenlujk ook geen ssl certifcaat meer nodig hebt met ipv6....

    Maar daar durf ik mijn ving3rs niet voor in het vuur te steken

    Vond u dit antwoord nuttig?

  8. zeromechanic Member
    Reactie geplaatst op: 10-11-2013 om 12:23

    Blijkbaar hebben node1 en node2 ipv6 ondersteuning.

    Node 9 weet ik zeker van niet, daar zat ik eerst op.

    .....ik had de boel verkloot een aantal maal....... dus vandaar.... gniffel

    Vond u dit antwoord nuttig?

  9. eenklant Member
    Reactie geplaatst op: 10-11-2013 om 20:08

    ha toch, top, zou dus moeten werken.

    Maar > RebuildNetwork Failed Virtual Machine #hje4kj85gnf35w

      Fatal: Can't connect to online server [159.253.5.94], force option not enabled!  Executing Rollback...

    Toch maar met versio contact opnemen.

    of weet iemand hier de oplossing.

    ik denk zelf mijn firewall.

     

    dan zou ik het volgende zelf niet moeten doen; forum.directadmin.com

    IPV6_DEFAULTGW=YOUR IPV6 GATEWAY

    dat zou enkel nullen achteraan zijn

    vb 2a02:27f8:1051:0:0:0:0:0

    IPV6ADDR=YOUR FIRST IPV6 IP ADDRESS

    dat is dan het tweede adres die aangemaakt is met cijfer achter de nullen

    vb 2a02:27f8:1051:0:0:0:0:9

    Vond u dit antwoord nuttig?

  10. eenklant Member
    Reactie geplaatst op: 10-11-2013 om 20:23

    maar als je de foutcode leest staat erbij force option not enabled! nu dan dat maar eens proberen hé, je moet deze optie activeren, wel raar dat je dat moet doen, het zou eigenlijk gewoon klikken RebuildNetwork moeten zijn

    daar gaan we dan weer RebuildNetwork Failed Virtual Machine #hje4kj85gnf35w dus optie force heeft ook niet geholpen, sterker nog het heeft mijn systeem uitgeschakeld.

    Vond u dit antwoord nuttig?

  11. eenklant Member
    Reactie geplaatst op: 10-11-2013 om 20:51

    "....ik had de boel verkloot een aantal maal....... dus vandaar.... gniffel"

    lol, zal ook eens doen, mss werkt het dan hahahaha.

     

    off

    Dammmm editten zou toch makkelijker zijn.

    dit is ook een leuke;

    "U ontvangt deze mail omdat u geabonnneerd bent op dit topic. Indien u geen e-mails meer wilt ontvangen, log dan in op uw klanten paneel en ga naar het desbetreffende topic. U kunt daar het abonnement verwijderen."

    ik zit me rot te zoeken waar dat staat, zie ik enkel als je wil reageren!!!!!!

    "Wilt u e-mails ontvangen wanneer er reacties geplaatst worden? U kunt deze instelling op ieder gewenst moment veranderen."

    Uw reactie bevat minder dan 5 tekens. Uw reactie moet minsten 5 tekens bevatten.

    pffffff

    Vond u dit antwoord nuttig?

  12. zeromechanic Member
    Reactie geplaatst op: 10-11-2013 om 22:29

    @eenklant,

    wat is jou prive email.

    Vond u dit antwoord nuttig?

  13. eenklant Member
    Reactie geplaatst op: 10-11-2013 om 23:08

    "wat is jou prive email."

    hmmm zulke zaken post ik niet graag, eentje speciaal voor hier "versio aapestaart bij punt be"

    Vond u dit antwoord nuttig?

  14. eenklant Member
    Reactie geplaatst op: 11-11-2013 om 02:36

    @zeromechanic

    Blijkbaar is er iets met je adres.

      This message was created automatically by mail delivery software.

     

    Mijn ipv6 werkt

    Vond u dit antwoord nuttig?

  15. zeromechanic Member
    Reactie geplaatst op: 11-11-2013 om 20:40

    He das mooi om te horen.
    ben benieuwd hoe je dit voorelkaar gekregen hebt..

    Zover ik weet is er niks mis met mijn mail.
    loopt via google apps, dus niet via versio

    Vond u dit antwoord nuttig?

  16. eenklant Member
    Reactie geplaatst op: 11-11-2013 om 22:10

    @zeromechanic

    ik kan je niet mailen krijg volgende fout;

    Mail delivery failed: returning message to sender

      This message was created automatically by mail delivery software.    A message that you sent could not be delivered to one or more of its  recipients. This is a permanent error. The following address(es) failed:      Jouwmail@adres      SMTP error from remote mail server after end of data:      host ASPMX.L.GOOGLE.COM [2a00:1450:4013:c01::1b]:      550-5.7.1 [mijn_ipv6_adres      16] Our system has detected that this message      550-5.7.1 does not meet IPv6 sending guidelines regarding PTR records and      550-5.7.1 authentication. Please review      550-5.7.1 https://support.google.com/mail/?p=ipv6_authentication_error for more      550 5.7.1 information. f8si7038200eep.105 - gsmtp

    Vond u dit antwoord nuttig?

  17. zeromechanic Member
    Reactie geplaatst op: 11-11-2013 om 22:14

    Ontvang je mijn emails wel ???

     

    Vond u dit antwoord nuttig?

  18. zeromechanic Member
    Reactie geplaatst op: 11-11-2013 om 22:30

    Lijkt erop dat jou ipv6 adres niet wordt geaccepteerd door google.
    je hebt geen PTR record voor dat domein in ipv6.

    google dondert hem er dus simpelweg uit.

    In NL hebben nog maar weinig, zeg maar bijna geen (XS4ALL uitgezonderd) native ipv6 ondersteuning
     

    Optie is om alleen ipv4 te gebruiken voor je mails

    Vond u dit antwoord nuttig?

  19. eenklant Member
    Reactie geplaatst op: 11-11-2013 om 22:41

    ja hoor ik ontvang jouw mail.

    het heeft te maken dat mij ipv6 geen PTR record heeft, staat ook in de link va google te lezen.

    eigelijk google dat moeilijk doet:

    http://christian.skala.me/blog/gmail-why-are-you-doing-this-to-me/#.UoFObBCBaSo

    http://tanguy.ortolo.eu/blog/article109/google-ipv6-smtp-restrictions

    ..........

    maar ik gebruik voor dat adres helemaal geen ipv6 adres, ik gebruik DNS beheer van versio en heb daar geen ipv6 toegevoegd en even min in directadmin van het domein, enkel de server ipv6 ready gemaakt met een ipv6 adres.

    via http://rdns6.com/hostRecord een ptr aangemaakt, kom er niet uit

    3.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.5.0.1.8.f.7.2.2.0.a.2.ip6.arpa 1h IN PTR mijndomein.tld

     

    Vond u dit antwoord nuttig?

  20. eenklant Member
    Reactie geplaatst op: 11-11-2013 om 23:07

    ok kan nu weer mailen naar google pfffffffffff

    gedaan door http://www.kendekeizer.nl/linux/ipv6-ptr-record-versus-google-mail/

    maar natuurlijk heb ik geen ipv6 meer, dus deze howto volgen http://help.directadmin.com/item.php?id=21 en dit topic door lezen http://www.webhostingtalk.nl/directadmin/177484-reverse-dns-op-dedicated-ip-van-user.html#axzz2k54bNpLw

    Vond u dit antwoord nuttig?

  21. eenklant Member
    Reactie geplaatst op: 12-11-2013 om 07:12

    dat PTR met ipv6 gedoe heb ik dus ook opgelost, hoop dat zo blijf werken.

    voor wie graag weet hoe:

    Ga naar: http://rdns6.com/hostRecord

    vul daar je ipv6 adres in, bij Fully Qualified Domain Name: vul je host naam in.

    je zal een output hebben vb 5.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.6.0.4.f.4.4.6.0.d.4.ip6.arpa

    Let op achter arpa staat ook een punt, je zal opmerken dat het je ipv6 adres omgedraait is en ipv dubbelpunt zijn het punten

    Ga nu naar je DNS Management(directadmin)/DNS beheer(versio) en maak daar en nieuw PTR record aan

    Ziet er dus zo uit

    5.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.6.0.4.f.4.4.6.0.d.4.ip6.arpa PTR jouwhost.tld

    ik heb er voor de zekerheid 3 aangemaakt

    5.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.6.0.4.f.4.4.6.0.d.4.ip6.arpa PTR mijnhost.tld

    5.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.6.0.4.f.4.4.6.0.d.4.ip6.arpa PTR vpsnaam.mijnhost.tld

    5.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.6.0.4.f.4.4.6.0.d.4.ip6.arpa PTR smptmail.mijnhost.tld

    Ga naar http://network-tools.webwiz.co.uk/dns-report.htm? vul daar je hostnaam in en kies voor ipv6 klik op report onderaan bij de resulaaten MX Mail Servers zal er volgende staan:

    MX Records MX Records obtained by local DNS Server:-

        jouw.mailhost.tld   [Preference: 10]  [TTL: 14400 - 4 Hours]

     

    Voor een ipv4 adres kan je dat ook aanmaken dat is simpeler.

    je draait je ip adres 1.2.3.4.5.6 gewoon om dus 6.5.4.3.2.1 en je moet gebruik maken van .in-addr.arpa

    Dus moet je 6.5.4.3.2.1.in-addr.arpa invullen host adres is zelfde als ipv6

     

    Indien ik verkeerd ben dat me dan iemand verbeterd

     

    je kan ook een ipv6 PTR zelf maken via SSH door host en dan het ipadres(ipv4/ipv6) in te typen

    ook je hostadres kan je via SSH weten door host en dan jouwdomeinnaam.tld in te typen

    # host jouwdomeinnaam.tld
    jouwdomeinnaam.tld has address 1.2.3.4.5.6
    zointer.be mail is handled by 10 jouw.mailhost.tld

     

    Vond u dit antwoord nuttig?

  22. eenklant Member
    Reactie geplaatst op: 12-11-2013 om 08:52

    "dat PTR met ipv6 gedoe heb ik dus ook opgelost, hoop dat zo blijf werken."

    Dus te vroeg geroepen

    Ik denk dat versio zal moeten contacteren hiervoor, voor dat domein gebruik ik hun DNS beheer dus ook hun nameservers en denk dat versio deze moet instellen, mijn ptr records zijn ingevul met de juiste gegevens.

    is wel raar dat het eerst wel werkte en nu niet?

    Vond u dit antwoord nuttig?

  23. zeromechanic Member
    Reactie geplaatst op: 12-11-2013 om 19:05

      reverse dns zal niet werken.

    Versio MOET alle IP in de dns zone gaan zett3n VOORDAT je zelf een ptr aan kan maken.

    Werkt eig3nlijk het z3lfde, alleen zonder het laatste getal. Pas daarna kun je zelf ptr aanmaken.

    @Versio

    Graag implementeren ook voor ipv4 !!!!

    Als er geen reverse mx is zullen een hoop spamservers rejecten......

    Voor ipV6 is dit zelfs nog belangrijker..... kijk maar wat google doet met ipv6 adressen.

    Versio, wees slim, implenteer ipv6 met razend tempo... wees eerder hiermee dan andere hosters!!

    Vond u dit antwoord nuttig?

  24. zeromechanic Member
    Reactie geplaatst op: 12-11-2013 om 19:08

      @eenklant

    Ik heb inneens een ideetje. Is misschien het testen waard

    Ik zal je vanaaf ff een mail sturen hierover...

    Vond u dit antwoord nuttig?

  25. Wesley Member
    Reactie geplaatst op: 15-11-2013 om 17:41

    Om een reverse te laten instellen op Ipv4 dien je te mailen naar support@versio.nl  Binnenkort is het mogelijk om dit via het klanten paneel zelf te doen.

    Vond u dit antwoord nuttig?