1. Rian Rous Member

    Joomla

    Topic geplaatst op: 27-07-2013 om 23:07

    M'n joomla sites zijn onlangs automatisch upgedate naar de laatste versie.
    Nu krijg ik een error:

    Error
    Your host needs to disable magic_quotes_gpc to run this version of Joomla!

    Een hoop knoppen zijn gewoon niet beschikbaar om aan de site te kunnen werken.
    (www.zorrodirtysister.eu en www.djdadivision.eu)

  2. Rian Rous Member
    Reactie geplaatst op: 27-07-2013 om 23:08

    Kan ik zelf iets ondernemen? Of zullen ze iets moeten veranderen aan de servers? Zijn er nog joomla users met dit probleem?

    Vond u dit antwoord nuttig?

  3. chatuliem Member
    Reactie geplaatst op: 28-07-2013 om 00:06

    Volgens mij moet je gewoon doen wat die waarschuwing zegt. magic_quotes_qpc uitzetten.
    Een keertje googelen en dan kom je op het volgende:

    I want to turn magicquotes OFF and i v read in
    http://www.php.net/manual/en/security.magicquotes.php#55935
    that..
    to turn of magic quotes put the following line into the .htaccess file:
    php_flag magic_quotes_gpc off.

    Zoals ik het lees open je dan het .htaccess bestand (of heb je htaccess.txt die nog niet hernoemd tot .htaccess, dan eerst hernoemen) en dan zet je de volgende zin erin:

    php_flag magic_quotes_gpc off.

    Ik weet niet of het werkt maar dit heb ik met google voor je gevonden.

    Vond u dit antwoord nuttig?

  4. chatuliem Member
    Reactie geplaatst op: 28-07-2013 om 00:25

    Kun je wel even vertellen of dit werkt? btw. de Joomla 3.0 versies worden niet aangeraden voor web sites, vanaf 3.5 wordt ie pas betrouwbaar. Het kan dus zijn dat daar het probleem eigenlijk ligt. 3.5 zou in september uitkomen.

    Vond u dit antwoord nuttig?

  5. Rian Rous Member
    Reactie geplaatst op: 28-07-2013 om 11:14

    Nee werkt niet, en wachten tot september om dingen te wijzigen, is geen optie.

    Vond u dit antwoord nuttig?

  6. chatuliem Member
    Reactie geplaatst op: 28-07-2013 om 15:15

    En weer teruggaan naar 2.5?

    Vond u dit antwoord nuttig?

  7. Mon Member
    Reactie geplaatst op: 31-07-2013 om 15:37

    Ik krijg ook die fout melding in joomla na automatische update. Is er intussen al een oplossing ?

    Vond u dit antwoord nuttig?

  8. Raymon Boone Member
    Reactie geplaatst op: 31-07-2013 om 17:05

    Zelfde probleem

    Vond u dit antwoord nuttig?

  9. Mon Member
    Reactie geplaatst op: 31-07-2013 om 21:42

    Joomla! 3.1.4 bevat een bug van hoge prioriteit

    Gepubliceerd op vrijdag 26 juli 2013 21:18
    Geschreven door Wouter (WoodyF4u)
    In de loop van vandaag is gebleken dat na updaten van Joomla! 3.1.2 naar 3.1.4 er een bug is meegekomen.
    Door een bug in JViewLegacy::getName() zijn er vele extensies die een error tonen: “500 Layout default not found”.
    Deze bug is inmiddels erkend en er wordt gewerkt aan een oplossing. Via deze link is het bugreport te volgen.

    Als je geen backup van Joomla 3.1.2 hebt die je terug kunt zetten en dit probleem herkent, kan je de volgende hotfix installeren zoals je een normale extensie installeert.

    Legacy.zip downloaden

    Een geüpdate versie (3.1.5) komt naar verwachting in de loop van deze week uit, dus als je nog niet geüpdate hebt, kan je beter even wachten met updaten. Joomla 3.1.4 lost alleen bekende fouten op, maar geen veiligheidsproblemen, dus je site loopt geen risico.

    De Joomla!-versie 3.1.x is nog steeds een ontwikkelversie en wordt pas omgezet naar een officiële ‘stable’-versie bij het vrijgeven van Joomla! 3.5.0 in de loop van 2014. Tot die tijd ontwikkelt het Joomla!-team nog aan deze 3.1.x-serie.
    Houd er dus altijd rekening mee dat een ontwikkelversie niet wordt aangeraden voor produktiesites

    Vond u dit antwoord nuttig?

  10. Rob Valk Member
    Reactie geplaatst op: 31-07-2013 om 22:11

    Hierbij een instructie die voor mij het probleem heeft opgelost!

    How to turn off magic quotes gpc for Joomla 3

    For most mainstream hosting companies running a CGI-Webinterface

    Steps:

    Create a php.ini file with the following:

    magic_quotes_gpc = Off
    extension=pdo.so
    extension=pdo_mysql.so

    Put it in your Joomla 3 root. Then change the htaccess.txt in your Joomla 3 root to .htaccess. Add the following lines to the .htaccess file (at the top) :


    suPHP_ConfigPath /home/myusername/public_html/yourJ3folder

    order allow,deny
    deny from all



    Change "myusername" and "yourJ3folder" to your respective folders. The "/home/myusername/public_html/yourJ3folder" can be found via the Global Configuration:

    In Joomla backend > System > System Information > [Directory Permissions], the folder is usually the same as the log directory (but without /logs at the end).
    .htaccess for some hosts

    For some hosts (Versio also), add "php_flag magic_quotes_gpc off" to the .htaccess file

    Vond u dit antwoord nuttig?

  11. chatuliem Member
    Reactie geplaatst op: 02-08-2013 om 16:22

    Als je nu gewoon het advies gevolgd had, nl. te wachten op 3.5, had je deze problemen niet gehad.

    Vond u dit antwoord nuttig?