1. Kemal Tas Member

    403 Forbidden error

    Topic geplaatst op: 26-07-2013 om 22:52

    Als ik mijn website http://www.slimmeledlamp.nl/ wil openen krijg ik sinds kort erg vaak de volgende foutmelding:
    Forbidden

    You don't have permission to access / on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

    Apache/2 Server at www.slimmeledlamp.nl Port 80

    Ik heb het al een aantal keer aan de helpdesk gevraagd, maar ze geven standaard antwoorden zoals: index niet aanwezig. Index is natuurlijk wel aanwezig en ik heb geen hoe het komt dat het soms wel en soms niet te bereiken is. Ben wel een tijdje terug verhuist van shared naar dedicated hosting.

  2. zeromechanic Member
    Reactie geplaatst op: 26-07-2013 om 23:11

    Wilde gok

    check de .htaccess eens.
    als daar een deny from all in staat krijg je dezeflde fout
    (mss per ongeluk een directory op protected gezet in DA ????)

    Vond u dit antwoord nuttig?

  3. Kemal Tas Member
    Reactie geplaatst op: 27-07-2013 om 00:32

    # 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

    # 2. In your opencart directory rename htaccess.txt to .htaccess.

    # For any support issues please visit: http://www.opencart.com

    Options +FollowSymlinks

    # Prevent Directoy listing
    Options -Indexes

    # Prevent Direct Access to files

    Order deny,allow
    Deny from all


    # SEO URL Settings
    RewriteEngine On
    # If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

    RewriteBase /
    RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
    RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !.*\\.(ico|gif|jpg|jpeg|png|js|css)
    RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
    RewriteCond %{HTTP_HOST} ^www\\.slimmeledlamp\\.nl [NC]
    RewriteRule (.*) http://slimmeledlamp.nl/$1 [R=301,L]

    ### Additional Settings that may need to be enabled for some servers
    ### Uncomment the commands by removing the # sign in front of it.
    ### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

    # 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
    # php_flag register_globals off

    # 2. If your cart has magic quotes enabled, This may work to disable it:
    # php_flag magic_quotes_gpc Off

    # 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
    # php_value upload_max_filesize 999M

    # 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
    # php_value post_max_size 999M

    # 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
    # php_value max_execution_time 200

    # 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
    # php_value max_input_time 200


    Ja er staat inderdaad deny from all, maar dit is enkel bij sommige bestanden. Dit zou niet moeten uitmaken.

    Vond u dit antwoord nuttig?

  4. Hans Meibergen Member
    Reactie geplaatst op: 27-07-2013 om 08:47

    Je mist wat:

    # Prevent Direct Access to files

    Order deny,allow
    Deny from all

    Vond u dit antwoord nuttig?

  5. Hans Meibergen Member
    Reactie geplaatst op: 27-07-2013 om 08:48

    # Prevent Direct Access to files
    de filesmatch .tpl|etc

    forum stript:(

    Vond u dit antwoord nuttig?

  6. chatuliem Member
    Reactie geplaatst op: 28-07-2013 om 09:34

    Zet een een hekje (#) voor Options +FollowSymlinks. Het kan zijn dat daar het probleem vandaan komt. Sommige providers hebben deze optie al voor je geïnstalleerd en als je dan in je .htaccess ook deze optie aan hebt, geeft ie errors.

    Vond u dit antwoord nuttig?