1. Albertjan Van Ittersum Member

    Joomla problemen na php update

    Topic geplaatst op: 11-06-2013 om 19:12

    Hallo,

    tot gisteren helemaal geen problemen gehad met de sites. vanmorgen zag ik een vreemde code
    Strict Standards: Declaration of JCacheControllerView::get() should be compatible with JCacheController::get($id, $group = NULL) in /home/../../../public_html/libraries/joomla/cache/controller/view.php on line 137

    Ik heb/had

    AddHandler x-httpd-php53 .php


    in .htaccess staan en mappen op 755 en bestanden op 644.

    als ik alleen AddHandler x-httpd-php53 .php of alles weg haal in htaccess is de foute regel weg. Grote probleem is dan dat ik echt met echt alles Rechtenproblemen heb...zelfs een plaatje uploaden lukt niet eens meer!!

    Weet iemand hoe ik dit kan oplossen?

  2. Albertjan Van Ittersum Member
    Reactie geplaatst op: 11-06-2013 om 19:14

    ..
    AddHandler x-httpd-php53 .php
    ..

    en dan zonder de puntens.. forum script haalt die regels weg

    Vond u dit antwoord nuttig?

  3. NightQuest Member
    Reactie geplaatst op: 11-06-2013 om 19:29

    Het probleem is dat je nu op PHP 5.4 zit, en daar gaat iets misgelopen zijn.
    Kan je de rechten op de folders nakijken? Bv. de folder uploads zou 755 moeten zijn, anders gaat het niet gaan.

    Als je de PHP 5.3 gebruikt dan is de rechtenregeling iets anders, wat bij jou de problemen veroorzaakt.

    Vond u dit antwoord nuttig?

  4. Albertjan Van Ittersum Member
    Reactie geplaatst op: 11-06-2013 om 19:56

    Precies ik had op een joomla forum ook gevonden dat Strict Standards: Declaration of JCacheControllerView etc.. door php 5.4 komt.

    Mijn oplossing was daarom om gewoon alles uit .htaccess te halen zodat ik in php 5.3 zit... Nu heb ik echter overal rechten problemen.

    Had de helpdeks al gemailt en in 5.3 zouden de mappen op 755 en bestanden op 644 moeten staan, maar ik kan u verzekeren dat dit echt niet werkt.

    Dus als u de oplossing heeft.. graag :D

    Vond u dit antwoord nuttig?

  5. lsikkens Member
    Reactie geplaatst op: 11-06-2013 om 20:54

    Ik heb exact hetzelfde probleem sinds vanochtend en de chat met de helpdesk biedt geen oplossing. Ook maar een mail gestuurd naar support@versio.nl

    Inmiddels op forums gelezen dat je de weergave van strict errors in php.ini kan uitschakelen (geadviseerd door Joomla) maar ik neem aan dat bij shared hosting dit niet kan.

    De eerdere mail van Versio spreekt over het feit dat je voorheen op php5.2 CLI zat en met de regels in .htaccess php5.3 CGI kon toepassen (voor mijn Joomla 3.x site)
    In dezelfde mail staat dat je nu op php5.3 CLI zit (ipv CGI) en dat het handhaven van de regels in .htaccess ervoor zorgt dat je op php5.4 CLI zit

    Lijkt dus logisch om dat aan te houden. Echter bij toepassen van deze regels in .htaccess krijg je inderdaad strict errors en bij het weghalen een rechtenprobleem.

    Aangezien ik niet wil tornen aan de beveiliging en rechteninstellingen (kortom .htaccess handhaven) lijkt de beste oplossing op die strict errors in php.ini uit te zetten (dat is aan Versio lijkt me)

    Vond u dit antwoord nuttig?

  6. Albertjan Van Ittersum Member
    Reactie geplaatst op: 11-06-2013 om 21:07

    Ik denk dat ik weet waardoor dit komt.
    De versio mail over de php upgrade heeft het over GCI en CLI
    Eerst draaide ik php 5.3 GCI met die toevoeging aan .htaccess.

    De mail heeft het erover dat het nu php 5.3 CLI is en geen GCI. GCI werkt met suPHP en dit schijnt veel van die rechten problemen op te lossen.

    Zou iemand van de helpdek hiernaar kunnen kijken want het is natuurlijk heel vaag dat php gisteren 5.3 was en vandaag ook.. alleen zijn er vandaag 1000 rechten problemen.

    Ben benieuwd naar een goede fix
    groeten

    Vond u dit antwoord nuttig?

  7. Tom Denkers Member
    Reactie geplaatst op: 11-06-2013 om 21:31

    Helaas is de betreffende joomla module/script niet compatible met php 5.4 CGI. Op dit moment is de enige methode te downgraden door de betreffende regel die hierboven vermeld staat uit uw htaccess te halen en het rechten probleem te ondervangen door middel van bepaalde mappen indien nodig de benodigde rechten te geven.

    Helaas heb ik geen idee wanneer joomla het probleem met php 5.4 verhelpt, hiervoor kunt u als community het beste contact met joomla opnemen. Op serverniveau kunnen wij helaas niks voor u aanpassen of verhelpen aangezien wij graag de nieuwste php versies hanteren vanwege veiligheid, performace en stabiliteit.

    Vond u dit antwoord nuttig?

  8. RobK Member
    Reactie geplaatst op: 11-06-2013 om 21:48

    Zet deze regel in twee bestanden van Joomla 1.5 dan kun je in ieder geval weer wat zien en inloggen en ben je 95% van de meldingen kwijt:

    error_reporting(E_ALL & ~E_STRICT);

    Ergens bovenin deze bestanden toevoegen via FTP:
    /index.php
    /administrator/index.php

    Voorbeeld:
    ---

    Vond u dit antwoord nuttig?

  9. RobK Member
    Reactie geplaatst op: 11-06-2013 om 22:04

    Hmmm, ik had wat regels met "PHP" geplakt en dat vond het forum niet leuk ;-)

    Als je de twee regels hebt ingevoegd log je in als admin op de backend en clear je de cache, dan ziet het er nog beter uit.

    Groeten, Rob

    Vond u dit antwoord nuttig?

  10. RobK Member
    Reactie geplaatst op: 12-06-2013 om 01:27

    Na enkele uurtjes zelfs een Joomla 1.0 site weer aan de praat gekregen met PHP 5.4!

    Vond u dit antwoord nuttig?

  11. GertS Member
    Reactie geplaatst op: 12-06-2013 om 06:18

    RobK bedankt voor de nuttige tips. Nog één fout houd ik over:
    Strict Standards: Only variables should be assigned by reference in /home/../domains/../public_html/plugins/content/jplayer/jplayer.php on line 32

    Iemand enig idee hoe ik deze foutmelding kan onderdrukken?

    Vond u dit antwoord nuttig?

  12. Albertjan Van Ittersum Member
    Reactie geplaatst op: 12-06-2013 om 11:12

    Goede morgen.
    Heb een aanvaardbare work around gevonden en draai nu in 5.4 en heb geen strict fouten meer.

    Dit is de truck. .htaccess aanpassen met
    plaatsen: enter AddHandler x-httpd-php53 .php enter hopelijk pakt het forum dit wel

    dan mappen op 755 en bestanden op 644

    Daarna bij global instellingen naar server gaan en Cache uit zetten. Gzip kan aan. Nu zijn de meldingen weg. Als je net als ik het warpframe gebruikt dan kan je in het template compressie gewoon aanzetten. dit geeft geen fouten.

    Hopelijk gaat versio snel naar 5.5 want wat ik heb gelezen op fora komen deze strict fouten echt door 5.4

    suc6 en de
    Groeten

    Vond u dit antwoord nuttig?

  13. Albertjan Van Ittersum Member
    Reactie geplaatst op: 12-06-2013 om 11:14

    Forum pakt die regels boven en onder addhandler etc niet.. google even op 5.3 versio en dan ziet u wat er omheen moet staan.. het is iest met filematch.. suc6

    Vond u dit antwoord nuttig?

  14. Sascha Vermassen Member
    Reactie geplaatst op: 12-06-2013 om 12:28

    Ik heb nu zelf de foutrapportage afgezet bij een J2.5 in de backend en de meldingen komen ook niet meer
    De rest qua rechten en co blijft hetzelfde alsook draaien in PHP5.4.

    Vond u dit antwoord nuttig?

  15. Albertjan Van Ittersum Member
    Reactie geplaatst op: 12-06-2013 om 16:12

    @ sascha
    jou fix werkt idd ook en met server cache aan is de site sneller.. net even in gmetrix getest, maar maakt wel uit.

    Met deze fix heb ik wel altijd 2 cache bestanden die niet te verwijderen zijn. Heeft dit impact?

    Vond u dit antwoord nuttig?

  16. ccbb Member
    Reactie geplaatst op: 13-06-2013 om 12:59

    Ik heb de foutrapportage op standaard gezet of op sommige sites moest ik zelf op Geen plaatsen.
    Daarmee zijn al mijn fouten eruit, maar wat betekent die foutrapportage uiteindelijk?
    Hier heeft Versio toch een steek laten vallen - niet leuk om je sites te zien 's morgens met al de foutmeldingen

    Vond u dit antwoord nuttig?

  17. Albertjan Van Ittersum Member
    Reactie geplaatst op: 14-06-2013 om 10:45

    Ik weet ook niet wat de functie van die foutrapportage eigenlijk is. Heb het ook uitgezet en om cache helemaal te legen zet ik dan caching in golbal even uit en leeg dan alles.

    Heb geen idee of dit nodig is, maar die fouten in het rapport zijn bij mij precies het cache onderdeel dat ik niet kan legen zonder het uit te zetten.

    Wat ik verder op forums heb gezien is dat dit probleem echt in php 5.4 zit. Die joomla test forums melden het en gaan er verder ook niet op in omdat het probleem bij php 5.4 zit. Hopelijk gaat Versio snel over op 5.5 gci en dan is alles weer okday... tot die tijd maar even de trucken uit dit forum toepassen :P

    Vond u dit antwoord nuttig?

  18. Elmer Korpel Member
    Reactie geplaatst op: 14-06-2013 om 16:02

    Beste Versio Gebruikers,

    Bedankt voor alle berichten in deze Topic. Door deze berichten is het gelukt om de fouten weg te halen van een aantal websites.

    Dit is wat ik heb gedaan met behulp van bovenstaande berichten.

    PHP 5.4 OPLOSSING:

    In de .htaccess voeg deze code toe dit zorgt ervoor dat je in php 5.4 draait. Er staat 5.3 maar dat is tegenwoordig 5.4 geworden.

    http://www.versio.nl/51-hoe_kan_ik_php_53_aanzetten.html

    In je joomla instellingen doe je het volgende:

    Caching = Off
    Gzip = On/Off maakt niet uit
    Error reporting = Simple

    De bestandsrechten dienen net zoals bij een normale joomla installatie op de volgende manier ingesteld te staan:

    Folders 755
    Files 644

    Nadat je deze dingen hebt gedaan werkt je Joomla site op PHP 5.4 en heb je geen bestandsrechten problemen. Ik weet niet of ik in de toekomst nog problemen hierdoor ga krijgen. Ik weet alleen dat er een behoorlijke groep mensen is die nu een heleboel werk hebben om de websites van hun klanten aan te passen. Want ja wat heb je aan een CMS als je niks kan opslaan. Haha.

    PHP 5.3 OPLOSSING:

    Tot slot als antwoord op Tom Denkers:

    U schrijft (Helaas is de betreffende joomla module/script niet compatible met php 5.4 CGI. Op dit moment is de enige methode te downgraden door de betreffende regel die hierboven vermeld staat uit uw htaccess te halen en het rechten probleem te ondervangen door middel van bepaalde mappen indien nodig de benodigde rechten te geven.)

    Ik heb dit geprobeerd en als ik de mappen op chmod 777 en de files op chmod 777 zet dan kan ik inderdaad Joomla gebruiken maar 777 is absoluut niet de bedoeling. Het alternatief is 757 maar dit is ook niet de bedoeling aangezien dit de veiligheid aantast van de website.

    http://stackoverflow.com/questions/5651180/is-chmod-757-safe

    Graag zou ik van Versio willen weten hoe ze dit gaan oplossen want zoals al eerder genoemd in dit forum. De meeste Joomla websites draaiden een aantal weken geleden al op PHP 5.3 zonder problemen.
    Wat ik hiervan weet is dat toendertijd werdt er gebruik gemaakt van PHP 5.3 CGI en nu PHP 5.3 CLI kan dit niet gewoon worden omgeschakelt. Misschien een heel erd dom voorstel maar in mijn ogen is het een juist voorstel.

    Nog even alles kort op een rijtje:

    PHP 5.4 OPLOSSING:
    1. Zet php 5.4 aan via http://www.versio.nl/51-hoe_kan_ik_php_53_aanzetten.html

    2. In Joomla configuratie doe het volgende Caching = Off, Gzip = On/Off maakt niet uit, Error reporting = Simple

    3. Zorg dat de bestandsrechten als volgt zijn ingesteld Folders 755,
    Files 644


    PHP 5.3 OPLOSSING:
    1. Zorg ervoor dat er geen x-httpd-php53 code in uw htaccess bestand staat.

    2. Zorg dat de bestandsrechten als volgt zijn ingesteld Folders 777,
    Files 777 of Folders 757, Files 757

    Bedankt voor alle posts in dit forum dat ervoor heeft gezord dat de websites weer werken.

    Vond u dit antwoord nuttig?

  19. Patrick Van Krugten Member
    Reactie geplaatst op: 17-06-2013 om 12:07

    Ik heb gedaan wat in het bericht van @Elmer Korpel staat.
    Maar als nog krijg ik bij mijn community de volgende error.

    Strict Standards: Only variables should be assigned by reference in /home/qgsuperqg/domains/quality-gaming.eu/public_html/123/plugins/system/jflibrary/jflibrary.php on line 88

    Op de rest van de site doet alles het prima.

    Groetjes en bedankt alvast

    Vond u dit antwoord nuttig?

  20. Elmer Korpel Member
    Reactie geplaatst op: 17-06-2013 om 13:53

    @Patrick Van Krugten

    Ik zou je graag willen helpen met deze fout weg te halen. Alleen ik zou graag de volgende dingen willen weten:

    1. Welke oplossing heb je gedaan 1 of 2
    2. Wat is de Joomla versie
    3. Welke SEO settings gebruik je
    4. Is htaccess ingeschakelt en standaard joomla htaccess.

    PS: Dit is handige informatie voor iedereen die je wilt helpen en ik raad dit aan voor iedereen die vragen heeft om deze gegevens te noemen.

    Vond u dit antwoord nuttig?

  21. Patrick Van Krugten Member
    Reactie geplaatst op: 17-06-2013 om 15:08

    Beide heb ik geprobeerd
    Joomla 2.5
    Momenteel SEO
    Friendly URLS YES
    Rewrite URLS NO
    Add Suffix NO
    Unicode NO

    Ik heb met rewrite ook al geprobeerd
    .htaccess staat aan

    Vond u dit antwoord nuttig?

  22. wihm Member
    Reactie geplaatst op: 17-06-2013 om 21:51

    @Patrick Van Krugten
    Zet error reporting op none

    @Elmer Korpel
    Onder PHP5.3 cli kun je ook de FTP layer van Joomla gebruken, dan hoef je niet alle folders open te zetten.

    Vond u dit antwoord nuttig?

  23. Aafje Brouwer Member
    Reactie geplaatst op: 18-06-2013 om 09:11

    Versio wijst alle verantwoordelijkheid weg, komt niet met oplossingen met dit php verhaal.
    de.htaccess werkt niet en wat er meer aangepast moet worden door je zelf worden er geen oplossingen aangedragen dan alleen deze verwijzing waar je ook niets mee kan.
    Dit alles is zeer service gericht en naar onze webwinkel geen omzet!

    Vond u dit antwoord nuttig?

  24. Patrick Van Krugten Member
    Reactie geplaatst op: 18-06-2013 om 10:03

    Rapport staat ook op none

    Vond u dit antwoord nuttig?

  25. wihm Member
    Reactie geplaatst op: 18-06-2013 om 11:40

    @Patrick Van Krugten
    Kijk of je de jfl ibrary plugin van JomSocial kunt updaten.
    Aders zit er niets anders op dan onder PHP5.3 cli te gaan draaien.

    Vond u dit antwoord nuttig?

  26. Duco Mansvelder Member
    Reactie geplaatst op: 18-06-2013 om 16:28

    Na migratie na php 5.4 onstonden er op mijn websites problemen als "Strict Standards: Only variables should be assigned by reference in /home/ME/domains/REGISTERNAME/public_html/modules/mod_sih/mod_sih.php on line 40"
    De oplossing is de onderstaande 3 regels uit .htaccess halen:


    AddHandler x-httpd-php53 .php


    Dit werkte bij mij naar behoren

    Vond u dit antwoord nuttig?

  27. Yezsnl Member
    Reactie geplaatst op: 19-06-2013 om 12:32

    Ja, maar ga maar eens iets proberen te installeren of uploaden (muv FTP-prog). Dat lukt niet meer, en voor het plaatsen van artikelen op webshops, installeren van coms en mods, uploaden van plaatjes op fora, etc. zeer vervelend !!!

    Vond u dit antwoord nuttig?

  28. Yezsnl Member
    Reactie geplaatst op: 19-06-2013 om 13:10

    Zoals hierboven beschreven, nogmaals in Jip en Janneke taal:

    Joomla 2.5.x geeft erg veel problemen in standaard setup. Erg tragisch dat dit niet eventjes beter wordt opgepakt door Versio.

    Vooralsnog zal deze oplossing in 99% van de gevallen werken, al is het niet zoals het hoort: Voeg de Addhandler toe aan je .htaccess bestand volgens deze richtlijnen: http://www.versio.nl/51-hoe_kan_ik_php_53_aanzetten.html (LET OP DE ENTERS!)

    Je website zal nu standaard een hoop fouten aangeven. Allemaal 'strict-errors'

    Ga nu naar je backend van je Joomla installatie en doe het volgende:

    1) Onder 'Algemene Instellingen' > Tab 'Server' > Zet 'Foutrapportage' op 'Geen'.
    2) Onder Tab 'Systeem' > Zet 'Cache' op 'UIT - Cachen uitgeschakeld'
    (GZIP compressie kan aan blijven!)

    Vond u dit antwoord nuttig?

  29. Hikmet Cercevik Member
    Reactie geplaatst op: 19-06-2013 om 17:23

    Als ik AddHandler x-httpd-php53 .php weg haal in .htaccess is de strict error regels weg, maar dan heb ik allerlei Rechten problemen, dus een of ander. Ik hoop dat dit probleem snel mogelijk opgelost is, want er zijn zo veel folders om rechten te geven en 777 is niet veilig.

    P.S:ik heb alles geprobeerd wat hier genoemd zijn, maar geen oplossing.

    Vond u dit antwoord nuttig?

  30. Yezsnl Member
    Reactie geplaatst op: 19-06-2013 om 17:53

    Voer uit wat ik hierboven uitgekauwd heb, en het zal werken. Ik heb talloze websites zo omgezet, en allemaal kassa.

    Vond u dit antwoord nuttig?

  31. Hikmet Cercevik Member
    Reactie geplaatst op: 19-06-2013 om 18:55

    Zoals heirboven vermeld heb ik al uitgeprobeerd het lukt niet.
    ik heb Joomla 1.5

    Vond u dit antwoord nuttig?

  32. Hikmet Cercevik Member
    Reactie geplaatst op: 20-06-2013 om 04:18

    Dank u wihm,

    Ik heb mijn probleem opgelost door FTP layer van Joomla 1.5 te gebruiken. Ik heb nu geen Rechten problemen meer op de folders
    Joomla 1.5 met PHP 5.3 CLI draait perfect.

    Mensen hoe je FTP Layer gebruiken is hier duidelijk beschreven.
    http://www.joomlacommunity.eu/nieuws/security/496-joomla-ftp-laag-veel-voorkomende-problemen-en-oplossingen.html

    Vond u dit antwoord nuttig?

  33. Aafje Brouwer Member
    Reactie geplaatst op: 20-06-2013 om 11:28

    Hallo,

    De oplossing van Yezsnl van 19-06-2013 werkte bij mij "strict errors" volledig weg. Mijn webwinkel draait weer.

    Vond u dit antwoord nuttig?

  34. Hans Van Haaren Member
    Reactie geplaatst op: 30-09-2013 om 16:52

    Een enkele klant draait op dit moment nog een Joomla 1.5.26 site. Als ik onder php 5.3 draai krijg ik met geen mogelijkheid de map (755)- en bestandsrechten(644) goed. Ze staan wel goed via ftp, maar in Joomla zijn de mappen niet schrijfbaar.

    Als ik de rechten verander naar 757, zoals hier beschreven werkt het wel, maar uit veiligheidsoverwegingen doe ik dat liever niet.

    Weet iemand hoe ik met Joomla 1.5.26 de map- en bestandsrechten op resp. 755 en 644 kan zetten zodat het wel werkt?

    Vond u dit antwoord nuttig?

  35. revo Member
    Reactie geplaatst op: 02-10-2013 om 19:31

    Ik gebruik de ftp layer niet, Ik heb nergens problemen mee

    Vond u dit antwoord nuttig?