1. Kvii Member

    PHP 5.5.0

    Topic geplaatst op: 18-01-2013 om 14:33

    Hallo iedereen,

    De programmeurs van PHP zijn druk bezig met hun aankomende versie, versie 5.5.0.
    Maar nu heb ik gelezen op de officiële website van PHP dat de standaard mysql functies verwijderd worden in volgende versies van PHP en niet meer te gebruiken zijn. Dit betekend dat heel veel websites niet meer zullen werken.

    Het bewijs: http://nl3.php.net/manual/en/function.mysql-connect.php

    Nu vraag ik me af of Versio binnenkort overstapt naar 5.5.0 of tijdelijk even wacht?

  2. zeromechanic Member
    Reactie geplaatst op: 18-01-2013 om 21:48

    Je leest niet geheel goed.

    de "oude" functie verdwijnt. Men gaat volledig over op de mysqli class.
    En deze draait ook al een tijdje mee.


    Een beetje (standaard)websitescript heeft ook de mogelijkheid om een mysqli driver te gebruiken.
    Er wordt al tijden ook geadviseerd om bij nieuwe projecten de mysqli class al te gebruiken.

    http://ca3.php.net/manual/en/mysqli.overview.php

    Versio ondersteund mysqli dus is het geen enkel probleem.
    zit nl standaard al in php va versie 5

    Vond u dit antwoord nuttig?