1. dempseyreijs Member

    Update failed (Wordpress themes)

    Topic geplaatst op: 10-12-2012 om 12:46

    Toen ik gisteren mijn wordpress themes (automatisch) wou updaten kreeg ik volgende error;

    The update process is starting. This process may take a while on some hosts, so please be patient.

    Updating Theme Twenty Eleven (1/2)

    Downloading update from http://wordpress.org/extend/themes/download/twentyeleven.1.5.zip…
    Unpacking the update…
    Installing the latest version…
    Removing the old version of the theme…
    Theme update failed.

    An error occurred while updating Twenty Eleven: Could not remove the old theme..
    Updating Theme Twenty Ten (2/2)

    Downloading update from http://wordpress.org/extend/themes/download/twentyten.1.5.zip…
    Unpacking the update…
    Installing the latest version…
    Removing the old version of the theme…
    Theme update failed.

    An error occurred while updating Twenty Ten: Could not remove the old theme..
    All updates have been completed.

    Ik ben wat beginnen rondzoeken op het internet over hoe ik dit probleem zou kunnen oplossen maar tevergeefs. Blijkbaar heeft wordpress de 'permission' niet de theme folder te verwijderen uit mijn directory en te vervangen met de nieuwe.

    Kennen jullie dit probleem en weten jullie hoe ik dit kan oplossen?

    Alvast bedankt!

  2. Hans van der Valk Member
    Reactie geplaatst op: 12-12-2012 om 07:47

    Ik heb exact hetzelfde probleem met twee "verse" installs van wordpress die ik deze week gemaakt heb. Het treedt overigens ook op bij het bijwerken van plugins.

    Het vreemde is dat een bestaande site die naar dezelfde versie van WP is geupdate dit probleem niet heeft. Ik heb al naar lees/schrijf rechten gekeken en die staan gewoon normaal. Het lijkt erop dat het probleem dieper zit.

    Een update vanochtend naar WP 3.5 lost het probleem ook niet op.

    Vond u dit antwoord nuttig?

  3. Danny Van Den Bosch Member
    Reactie geplaatst op: 12-12-2012 om 18:19

    Ook ik heb hetzelfde probleem, ik kan geen plugins installeren en updaten, hopelijk heeft er iemand meer informatie

    Vond u dit antwoord nuttig?

  4. Fabien Versio medewerker
    Reactie geplaatst op: 14-12-2012 om 05:30

    Hallo, gebruiken jullie reeds php5.3 op de hosting? Meer info op https://www.secure.versio.nl/nieuwsartikel.php?id=52 Anders misschien ook even kijken naar deze post: http://wordpress.org/support/topic/plugin-upgrade-failing-cannot-remove-old-plugin

    Vond u dit antwoord nuttig?

  5. Danny Van Den Bosch Member
    Reactie geplaatst op: 14-12-2012 om 15:29

    Ik krijg het niet voor elkaar op php5.3 te krijgen, ik doe het gewoon in het htacces bestand

    Vond u dit antwoord nuttig?

  6. Fabien Versio medewerker
    Reactie geplaatst op: 14-12-2012 om 16:56

    @Danny, heb je de 3 regels code helemaal bovenaan je .htaccess bestand geplaatst? Nadien via de file manager de rechten van mappen op 755 zetten en bestanden op 644.

    Vond u dit antwoord nuttig?

  7. Augus Van Gils Member
    Reactie geplaatst op: 16-12-2012 om 11:26

    Heeft niks met rechten te maken, is met instelling van de hoster (versio dus). Dit is simpel op te lossen door je core-update van wordpress te doen door de back-end (phpmyadmin inloggen zie je daar upgrade). Daarna ben je in staat om al je themes en plugins bij te werken.

    Vond u dit antwoord nuttig?

  8. Danny Van Den Bosch Member
    Reactie geplaatst op: 16-12-2012 om 19:04

    Door die code helemaal bovenaan te zetten is het toch gelukt, ik had hem er eerst onder gezet dus het is opgelost! Bedankt!!

    Vond u dit antwoord nuttig?

  9. Fabien Versio medewerker
    Reactie geplaatst op: 18-12-2012 om 20:22

    @Danny Fijn te horen dat het probleem opgelost is.

    Vond u dit antwoord nuttig?

  10. Violeta Klimaviciene Member
    Reactie geplaatst op: 19-09-2014 om 18:37

    Please advise how to solve this with update to Wordpress 4.0:
    Warning: copy(/home/...................../public_html/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: Permission denied in /home/............./public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 217

    The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.: wp-admin/includes/update-core.php

    Installation Failed

    I am not good in C panel operation to figure these permissions.
    Thank you for any help.

    Vond u dit antwoord nuttig?

  11. Gerald Versio medewerker
    Reactie geplaatst op: 20-09-2014 om 01:42

    You can try to run your website in PHP 5.4 modus:
    http://www.versio.nl/61-hoe_kan_ik_php_54_aanzetten.html

    When using PHP 5.4 all directory permissions need chmod 755 and files chmod 644.

    Vond u dit antwoord nuttig?