1. Jesse Dobbelaere Member

    Php 5.3.3

    Topic geplaatst op: 30-10-2012 om 21:57

    Is er al een mogelijkheid om Php 5.3.3 te draaien? Ik ben een website aan het ontwikkelen met Symfony2 framework, en daarvoor is minimum versie 5.3.3 een vereiste...

  2. zeromechanic Member
    Reactie geplaatst op: 30-10-2012 om 21:59

    https://www.secure.versio.nl/nieuwsartikel.php?id=52

    Vond u dit antwoord nuttig?

  3. Jesse Dobbelaere Member
    Reactie geplaatst op: 30-10-2012 om 22:12

    Ja dat heb ik inderdaad al gedaan. Mijn basisinstallatie van Symfony2 werkt echter nog steeds niet. Als ik phpinfo(); opvraag, zie ik echter dat dit PHP 5.3.1 is, en ik heb 5.3.3 nodig. Het kan nog wel even duren zeker voordat Versio naar 5.3.3 upgrade?

    Vond u dit antwoord nuttig?

  4. zeromechanic Member
    Reactie geplaatst op: 30-10-2012 om 22:58

    Heb je symphony nodig, of een framework?

    kijk anders eens naar codeigniter, daar werk ik veel mee.

    kan ook geen requirements vinden voor symphony

    Vond u dit antwoord nuttig?

  5. Jesse Dobbelaere Member
    Reactie geplaatst op: 31-10-2012 om 03:10

    Het is momenteel gelukt denk ik. Symphony heeft requirements van PHP 5.3.2 maar het werkt op mijn lokale MAMP op PHP 5.3.14 en op Versio met diezelfde php versie blijkbaar. Ik had misschien problemen door de permissions vermoed ik.

    Vond u dit antwoord nuttig?

  6. RayHammer Member
    Reactie geplaatst op: 31-10-2012 om 07:38

    Als je van php 5.2 naar 5.3 gaat moet je de mappen op 755 en bestanden op 644 zetten. Daarmee zal het probleem zeker opgelost zijn.

    Vond u dit antwoord nuttig?

  7. Vetzo Member
    Reactie geplaatst op: 11-11-2012 om 22:39

    Ik wil met installatron OwnCloud installeren voor op mijn website.
    De installatie mislukt, omdat OwnCloud PHP 5.3.3 nodig heeft, maar
    ziet dat versie er nog een oude PHP5.2 draait.
    Wanneer wordt die bijgewerkt?
    Bij voorbaat dank

    Vond u dit antwoord nuttig?

  8. Fabien Versio medewerker
    Reactie geplaatst op: 14-11-2012 om 01:25

    Hallo Nvt Nvt, kijk even naar deze link voor php5.3 op je hosting te activeren. Op de speciale hosting pakketten draait het meteen onder php5.3.

    Vond u dit antwoord nuttig?

  9. MEEUW Member
    Reactie geplaatst op: 19-11-2012 om 15:37

    Hoe kan ik per domeinnaam zorgen dat ik php 5.3 heb? Ik heb een resellers pakket. Om contact.php53 de klant in te tikken is wat verwarrend ;).

    Vond u dit antwoord nuttig?

  10. Fabien Versio medewerker
    Reactie geplaatst op: 21-11-2012 om 00:45

    @MEEUW Je kan het .htaccess bestand met php5.3 code toevoegen in de public_html map van elk domein: https://www.secure.versio.nl/nieuwsartikel.php?id=52

    Vond u dit antwoord nuttig?

  11. blueMen Member
    Reactie geplaatst op: 18-12-2012 om 15:51

    Quote: "Fabien Daniel [Versio medewerker] op 14-11-2012 om 01:25
    Hallo Nvt Nvt, kijk even naar deze link voor php5.3 op je hosting te activeren. Op de speciale hosting pakketten draait het meteen onder php5.3."

    Mijn vraag: Welke link? Ik kan op dit moment bepaalde CMS pakketten niet installeren omdat ik de volgende melding krijg in Installatron:

    Requirements:
    php-version-minimum v5.3.2 (detected: v5.2.17)

    Please advise..

    Vond u dit antwoord nuttig?

  12. Fabien Versio medewerker
    Reactie geplaatst op: 18-12-2012 om 20:16

    @blueMen De link net boven je reactie zal het probleem oplossen, hierbij nogmaals de link: https://www.secure.versio.nl/nieuwsartikel.php?id=52 Code helemaal bovenaan je .htaccess bestand plaatsen.

    Vond u dit antwoord nuttig?

  13. Leonie Kramer Member
    Reactie geplaatst op: 26-01-2013 om 14:00

    Ik heb hetzelfde probleem. het nu een .htacces bestand op de server gezet met de code erin, maar blijf de melding krijgen, kunnen jullie dit gaan oplossen please?

    Vond u dit antwoord nuttig?

  14. jost Member
    Reactie geplaatst op: 27-01-2013 om 15:03

    Ik heb alle mappen op 755 en alle bestanden op 644 gezet, caching opgeschoond en daarna zelfs uitgeschakeld. Maar als ik de code


    AddHandler x-httpd-php53 .php


    bovenin m'n .htaccess file zet krijg ik toch steeds een 500 error
    De .htaccess file staat in de folder public_html
    Wat moet er verder nog gebeuren om zonder foutmeldingen php5.3 te gebruiken???

    Vond u dit antwoord nuttig?

  15. Fabien Versio medewerker
    Reactie geplaatst op: 28-01-2013 om 04:18

    Staat de code helemaal bovenin het .htaccess bestand? Nadien even alle mappen en bestanden van je website nakijken, 755 voor mappen en 644 voor bestanden, ook de bovenliggend mappen nakijken. Mogelijk staan er nog mappen waar je de tekst "recursively" ziet staan in de kolom "Action" in die file manager van DirectAdmin, deze rechten kan je dan meteen ook even resetten.

    Vond u dit antwoord nuttig?

  16. jost Member
    Reactie geplaatst op: 29-01-2013 om 21:02

    Dankjewel; ik had alleen public_html en alles daaronder op 755 en 644 gezet. Nu ook de root en andere mappen die direct onder de root (en dus op zelfde niveau als public_html: .htpassword, logs, public_ftp, stats) zitten gedaan en nu werkt het.

    Vond u dit antwoord nuttig?