1. Frib Member

    Update naar Joomla 3.0.0

    Topic geplaatst op: 29-09-2012 om 07:54

    Na de update van Joomla 2.5.7. naar de nieuwe versie 3.0.0 krijg ik de volgende foutmelding: Your host needs to use PHP 5.3.1 or higher to run this version of Joomla! Is er wat misgegaan in de update of moet de host de PHP versie nog aanpassen?

  2. display Member
    Reactie geplaatst op: 29-09-2012 om 08:06

    Ja, ik krijg dat zelfde, heb het dus terug gezet naar 2.5.7 maar krijg toch nog een foutmelding n.l.
    Fatal error: Cannot redeclare class JDispatcher in /home/XXXXXXXXX/domains/XXXXXXXXXXXXXXXXXX.nl/public_html/libraries/joomla/event/dispatcher.php on line 279
    Zodat ik dus nu helemaal niets meer heb.

    Vond u dit antwoord nuttig?

  3. Patrick25 Member
    Reactie geplaatst op: 29-09-2012 om 09:05

    Ik ervaar hetzelfde probleem, graag z.s.m. PHP updaten naar versie 5.3.1, want zo zijn mijn sites (en die van anderen) compleet onbruikbaar!

    Vond u dit antwoord nuttig?

  4. Marw Member
    Reactie geplaatst op: 29-09-2012 om 10:14

    Ook het zelfde probleem eerst backup gemaakt daarna geupdate naar versie joomla v 3.0 en ja hoor problemen met PHP. heb de site terug herstelt en ja hoor web is de site
    Wat nu??? dit kost mij geld hoor

    Vond u dit antwoord nuttig?

  5. John Van Vugt Member
    Reactie geplaatst op: 29-09-2012 om 10:37

    Same here bij www.spawellnessmassage.nl (heb de backup terug gezet maar dit werkt ook niet nu krijg ik hele andere meldingen). Dus de backup functie werkt ook niet helemaal goed in dit geval.

    Vond u dit antwoord nuttig?

  6. Kees Hofman Member
    Reactie geplaatst op: 29-09-2012 om 11:08

    Ik had dit probleem ook. Wat ik heb gedaan is het volgende.
    Verwijder alle bestanden en zet dan pas de backup terug. Er waren namelijk bestanden die van "owner" was veranderd. Daarom heb ik ze gereset en verwijderd en vervolgens backup terug gezet.
    Nu werkt mijn website weer zoals hij deed zonder de update.

    Vond u dit antwoord nuttig?

  7. Frib Member
    Reactie geplaatst op: 29-09-2012 om 12:38

    Bedankt Kees, heb hetzelfde gedaan en idd de versie 2.5.7 is weer terug en de website werkt weer als normaal. Ik weet alleen niet wat er gebeurt als je, voordat je ging updaten, een backup hebt gemaakt van een gedeelte van je website.
    Heb ook even gekeken bij http://www.joomlanl.nl/ en zal het advies maar even opvolgen en wachten tot versie 3 helemaal stable is.

    Vond u dit antwoord nuttig?

  8. Karina Bauwmans Member
    Reactie geplaatst op: 29-09-2012 om 13:07

    Ik zit met hetzelfde probleem.
    Als ik mijn website open krijg ik dit:
    http://ya.ru/
    Zet ik in .htaccess dit:


    AddHandler x-httpd-php53 .php


    dan krijg ik:PHP updaten naar versie 5.3.1,
    Al verscheidene malen hulp gevraagd via chat en email, maar steeds hetzelde antwoord: HET MOET WERKEN ZO!
    Maar het werkt niet.
    Ik heb meerdere websites lopen op versio, dus dit beloofd voor de toekomst!

    Vond u dit antwoord nuttig?

  9. Jan Huibers Member
    Reactie geplaatst op: 29-09-2012 om 13:23

    Your host needs to use PHP 5.3.1 or higher to run this version of Joomla!

    ook deze melding

    Vond u dit antwoord nuttig?

  10. Fabien Daniel Versio medewerker
    Reactie geplaatst op: 30-09-2012 om 02:59

    Plak de code die je op onderstaande link vindt even helemaal bovenaan het .htaccess bestand in de public_html map:

    https://www.secure.versio.nl/nieuwsartikel.php?id=52

    Nadien zorgen dat alle mappen op 755 staan, bestanden op 644. Ook nagaan via de FileManager in DirectAdmin dat je gebruikersnaam staat vermeld in de kolom UID/GID.

    Vond u dit antwoord nuttig?

  11. Patrick25 Member
    Reactie geplaatst op: 30-09-2012 om 10:23

    @Fabien:
    Vervolgens krijg ik deze melding:

    Fatal error: Call to undefined method JRegistry::getValue() in /home/pvg/domains/patrickvangils.com/public_html/templates/patrickvangilsjoomla/functions.php on line 587

    Vond u dit antwoord nuttig?

  12. Fabien Daniel Versio medewerker
    Reactie geplaatst op: 30-09-2012 om 19:00

    @Patrick25 Gebruik je toevallig een oudere versie van Artisteer?

    Vond u dit antwoord nuttig?

  13. Patrick25 Member
    Reactie geplaatst op: 30-09-2012 om 22:45

    @Fabien: Ik gebruik een zeer recente versie van Artisteer voor mijn templates: 3.1.0.55575

    Vond u dit antwoord nuttig?

  14. neuron Member
    Reactie geplaatst op: 02-10-2012 om 21:39

    Via DirectAdmin is Joomla niet te installeren?...heeft iemand dat zelfde probleem?

    Vond u dit antwoord nuttig?

  15. neuron Member
    Reactie geplaatst op: 03-10-2012 om 11:40

    Ben al dagen met het zelfde probleem bezig met Versio,..ook ik krijg Joomla 3.0 of welke andere versie dan ook niet geinstalleerd, blijf al hangen in het installatiescherm van DirectAdmin, ...en krijg de mededeling dat PHP5.3 geinstalleerd moet zijn.......ik wacht af op het antwoord! Ook handmatige installatie van Joomla lukt niet,..ook al pas ik de htaccessfile aan.

    Vond u dit antwoord nuttig?

  16. Fabien Daniel Versio medewerker
    Reactie geplaatst op: 04-10-2012 om 03:54

    Hallo, staat de code (de 3 regels) van deze link: https://www.secure.versio.nl/nieuwsartikel.php?id=52 helemaal bovenaan je .htaccess bestand in de public_html map van je domein?

    Let op dat je dit niet aanmaakt in de public_html map van het tijdelijk subdomein dat op je hosting gekoppeld staat indien je op een eigen domein werkt. Steeds naar de map domains -> uw-domein.nl -> public_html

    Welke melding krijg je nadien bij het installeren via DirectAdmin of handmatig?

    Vond u dit antwoord nuttig?

  17. Paulus Van Den Heuvel Member
    Reactie geplaatst op: 06-10-2012 om 14:07

    Ben vandaag ook bezig geweest om te proberen Joomla 3.0 aan het werken te krijgen. Is me niet gelukt, ondanks aanpassingen in htaccess bestand en ander tips hierboven. Steeds opnieuw de foutmelding: Your host needs to use PHP 5.3.1 or higher to run this version of Joomla! Na 3 pogingen alles maar weer teruggezet naar 2.5.7.. Wachten nog maar even af of Versio met een betere oplossing komt. Is wel heel erg vervelend en balen.

    Vond u dit antwoord nuttig?

  18. zeromechanic Member
    Reactie geplaatst op: 06-10-2012 om 16:26

    Beste mensen.

    mij lukt het wel in de eerste keer.

    voor jullie heb ik hetvolgende gedaan :

    installatie via installatron :
    dit werkt inderdaad niet, ook niet met de addhandler in de htaccess.
    mss te maken dat installatron boven de webroot werkt.

    zelf installeren, download via joomla zelf.
    0) database aangemaakt
    1) htaccess aangemaakt in de public_html
    2) alle joomla bestanden geupt
    3) index.html verwijderd (ivm het standaard scherm bij een nieuw domein)
    4) installatie opgestart.
    5) krijg direct een install scherm.
    6) magic quotes gpc staan aan, deze moeten dus uit.
    7) magic quotes uitgezet (zet ik onderaan neer), opnieuw laten controleren
    8) vervolgens alle stappen doorlopen
    9) een werkende joomla site : joomla.zeromechanic.nl (staat op server 1)
    10) alles zonder problemen

    uitzetten magic_quotes_GPC :

    maak in de public_html het volgende bestand :

    .user.ini

    LETOP de 1e punt !!!!

    zet vervolgens onderstaande in dat bestand :
    magic_quotes_gpc = Off
    magic_quotes_runtime = Off
    magic_quotes_sybase = Off

    Vond u dit antwoord nuttig?

  19. wihm Member
    Reactie geplaatst op: 07-10-2012 om 16:05

    Klopt helemaal, zeromecanic. Zie ook hier.

    http://docs.joomla.org/Potential_backward_compatibility_issues_in_Joomla_3.0_and_Joomla_Platform_12.1

    Het is overigens ten zeerste af te raden om Joomla! met Installatron te upgraden omdat er nogal eens databasewijzigingen worden vergeten. Gebruik liever de ingebouwde updatefunctie van Joomla! zelf. Werkt perfect.

    Vond u dit antwoord nuttig?

  20. MikyB-73 Member
    Reactie geplaatst op: 07-10-2012 om 17:43

    Jammer dat het via installatron niet werkt.

    Mooie oplossing zeromechanic, ben er bijna maar lukt me alleen niet magic quotes gpc uit te zetten. Ik blijf hangen in de pre-installer.
    Heb het geprobeert met .user.ini maar zonder resultaat.
    Iemand nog tips of ideeen hoe dat kan?
    Gr, MB

    Vond u dit antwoord nuttig?

  21. zeromechanic Member
    Reactie geplaatst op: 07-10-2012 om 17:46

    Ik ben zowiezo niet kapot van installatron
    ik heb het ook standaard uit staan bij mijn klanten
    alleen maar om een hoop "gezeik en gezanik" te voorkomen.

    Als het moet installeer ik het zelf wel voor de klant.
    is uiteindelijk sneller dan om de eventuele installatron problemen te verhelpen.

    Vond u dit antwoord nuttig?

  22. zeromechanic Member
    Reactie geplaatst op: 07-10-2012 om 17:49

    @mikyB

    de .htaccess en de .user.ini dienen beide in de public_html te staan.
    dan gelden ze ook voor je subdomeinen.

    de betreffende instellingen in die bestanden zijn "per directory" mogelijk

    Vond u dit antwoord nuttig?

  23. MikyB-73 Member
    Reactie geplaatst op: 07-10-2012 om 20:01

    @zeromechanic
    Heb ze beide in public_html staan
    in .htaccess heb ik dit staan helemaal bovenin (kopie via chrome)


    AddHandler x-httpd-php53 .php

    en in .user.ini dit staan
    magic_quotes_gpc = Off
    magic_quotes_runtime = Off
    magic_quotes_sybase = Off

    Vond u dit antwoord nuttig?

  24. zeromechanic Member
    Reactie geplaatst op: 07-10-2012 om 20:15

    @mikyB

    dan moet ik het even zien.
    andrs weet ik het ook zo niet.
    is moeilijk om via forum te bepalen wat er evt mis is.

    indien gewenst, stuur me even een mailtje naar zeromechanic (at) gmail.com

    Vond u dit antwoord nuttig?

  25. zeromechanic Member
    Reactie geplaatst op: 07-10-2012 om 21:37

    Ik heb even mee gekeken op de site van MikyB.

    Het probleem is daar nu opgelost.
    Er stonden in zijn geval een aantal fouten in de .user.ini

    Voor iedereen :
    Gebruik een GOEDE html/php editor
    bv : HTMLkit of Netbeans PHPIde
    gebruik geen wordpad en of notepad
    bij foutmeldingen wordt er vaak ook een regelnummer aangegeven, deze worden in de note/wordpad niet weer gegeven.

    let bij knippen en plakken tevens goed op dat er geen ander code mee komt.
    Dat is waarschijnlijk in dit geval ook zo geweest.

    Vond u dit antwoord nuttig?

  26. Tjerkdj Member
    Reactie geplaatst op: 10-10-2012 om 08:42

    Zou het niet beter zijn als je in directadmin voor je php versie kan kiezen? Beste helpdesk kijk een hier http://www.outservices.net/phpvs.php

    Vond u dit antwoord nuttig?

  27. Wesley Berendsen Versio medewerker
    Reactie geplaatst op: 09-11-2012 om 12:37

    U kunt uw website in php-5.3 modus draaien. Op deze manier krijgt u geen problemen met rechten. Voeg het volgende toe aan uw .htaccess file:

    AddHandler x-httpd-php53 .php

    Als u nu een error krijgt dan kunt u deze error opzoeken via directadmin onder "Statistics and logs". Hier kunt u de apache errors inzien. Als het een rechten probleem is kunt u deze rechten resetten via de filemanager van directadmin. Is de error u niet bekend dan kunt u deze naar ons doorsturen.

    Ook dienen de rechten van de mappen met php 5.3 in de public_html op 755 te staan, en alle bestanden op 644. LET OP dit geld ook op alle onderliggende mappen in de public_html. Het is helaas nog niet mogelijk om Joomla 3.0 via installatron te installeren. Dit zult u helaas nog met de hand moeten doen.

    Vond u dit antwoord nuttig?

  28. Wesley Berendsen Versio medewerker
    Reactie geplaatst op: 09-11-2012 om 12:37

    Hij pakt niet de hele code, zie daarom mijn pastebin.

    http://pastebin.com/PQhmxXF8

    Vond u dit antwoord nuttig?

  29. Christiaan Bollen Member
    Reactie geplaatst op: 26-12-2012 om 22:19

    Zelf heb ik lang gezocht achter een oplossing. Bovenstaande reacties werkte niet voor mij. Dit was de oplossing die bij mij wel werkte.

    Plaats het volgende in je htaccess:

    php_flag magic_quotes_gpc Off

    Vond u dit antwoord nuttig?

  30. Zsolt Boda Member
    Reactie geplaatst op: 06-08-2013 om 07:53

    Hi Guys,
    I have the same problem. It looks to me you found a solution but I don't speak dutch. Can someone please translate the solution. TIA!

    Vond u dit antwoord nuttig?